Jump to content
shadow00caster

Error on Debian 9.1 Stretch

Recommended Posts

I have Pulseway installed on a fresh Debian 9.1 box and receive the below error:

pulseway[24336]: /usr/sbin/pulsewayd: error while loading shared libraries: libssl.so.0.9.8: cannot open shared object file: No such file or directory
 

Any advice?

Share this post


Link to post
Share on other sites

Hi,

Currently we do not support openssl1.1, therefore you will need to install openssl 0.9.8

Share this post


Link to post
Share on other sites

My Linux skills are rusty, but I have two questions.  How did you determine this was your error?  I installed Pulseway on a new Raspberry Pi with Debian Stretch.  Pulseway will not start.  SystemCtrl Status says Pulseway exited, but when I look at the config.xml file, the password has not yet been encrypted.  I have another raspberry pi that was upgraded from Jessie, and that is running fine with Pulseway.

I was able to confirm that openssl 1.1 is installed via the openssl version command, but how does one get the old version installed?  I couldn't find an older version to download. I think it's because there was a security flaw.  Will Pulseway be updating their agent so that it works with 1.1?

 

Share this post


Link to post
Share on other sites

Hi,

I have installed the Debian GNU/Linux 9.0 (stratch) on one of mine VM's and the issue was with libssl1.0.1.

As soon as I installed libssl0.9.8 the Pulseway service was started without any errors.

wget http://snapshot.debian.org/archive/debian/20110406T213352Z/pool/main/o/openssl098/libssl0.9.8_0.9.8o-7_amd64.deb

Please check this article.

Quote

According to solidot April 7 report, OpenSSL has released a 1.0.1g repair bug, Debian distribution in half an hour to repair bug, Fedora issued a correction scheme of an expedient. The bug was introduced in 2011 in OpenSSL, Use the OpenSSL 0.9.8 found that version is not affected, But Debian Wheezy, Ubuntu 12.04.4, CentOS 6.5, Fedora 18, SUSE 12.2, OpenBSD 5.4, FreeBSD 8.4 and NetBSD 5.0.2 version are affected. If the system allows you as concentrated, recommended patches to 1.0.1g or above.

 

Share this post


Link to post
Share on other sites

Having the same problem on a fresh install of Raspbian Strech Lite on my Raspberry Pi:

Sep  7 22:21:21 pidp8 pulseway[11554]: /usr/sbin/pulsewayd: error while loading shared libraries: libssl.so.1.0.0: cannot open shared object file: No such file or directory

Is there a way to fix this other than downgrading libssl?
 

 

Share this post


Link to post
Share on other sites
30 minutes ago, windracer said:

Having the same problem on a fresh install of Raspbian Strech Lite on my Raspberry Pi:


Sep  7 22:21:21 pidp8 pulseway[11554]: /usr/sbin/pulsewayd: error while loading shared libraries: libssl.so.1.0.0: cannot open shared object file: No such file or directory

Is there a way to fix this other than downgrading libssl?
 

 

This is exactly what I'm working with.  I deployed a Pi on a client site and I want to monitor it.

On ‎9‎/‎4‎/‎2017 at 7:22 AM, Chris said:

Hi,

I have installed the Debian GNU/Linux 9.0 (stratch) on one of mine VM's and the issue was with libssl1.0.1.

As soon as I installed libssl0.9.8 the Pulseway service was started without any errors.

wget http://snapshot.debian.org/archive/debian/20110406T213352Z/pool/main/o/openssl098/libssl0.9.8_0.9.8o-7_amd64.deb

Please check this article.

 

Thank you for this Chris.  Do you know where we can get the ARMHF version of this package in version 0.9.8?
I searched on the page https://www.debian.org/distrib/packages  and came up empty.

I also tried:  sudo apt-get install libssl0.9.8 but the response was:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libssl0.9.8 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package 'libssl0.9.8' has no installation candidate

It would be really great if Pulseway would accept the latest version of openSSL.  Is that possible?

Share this post


Link to post
Share on other sites

Hi all,

Last week on Thursday we released a new version of the Linux agent. This version supports up to openssl 1.0.2

Share this post


Link to post
Share on other sites
On ‎9‎/‎11‎/‎2017 at 6:58 AM, Chris said:

Hi all,

Last week on Thursday we released a new version of the Linux agent. This version supports up to openssl 1.0.2

Awesome, thank you.  Is that version 5.3?

Share this post


Link to post
Share on other sites

5.3 still isn't working for me:

Sep 15 18:17:46 pidp8 systemd[1]: Starting LSB: Monitor and Control Everything IT from Any Smartphone or Tablet...
Sep 15 18:17:47 pidp8 pulseway[1119]: Illegal instruction
Sep 15 18:17:47 pidp8 systemd[1]: Started LSB: Monitor and Control Everything IT from Any Smartphone or Tablet.

So it thinks it's started, but it's not. 
 

 

Share this post


Link to post
Share on other sites

Oh, I see why. I misread the note about the 5.3 agent. It only supports OpenSSL 1.0.2 and my Pi is running 1.1.0f. That's probably the cause still of the illegal instruction. But I do have libssl1.0.2l-2 installed on my Pi. Shouldn't that allow the agent to work? I'd rather not have to go back and rebuild this Pi using Jessie just to get back to an older OpenSSL build just to run the Pulseway agent.

Edited by windracer

Share this post


Link to post
Share on other sites

Hi,

Please send an email to support@pulseway.com and add the output of this command: grep -i pulseway /var/log/syslog

Also, double-check if the config.xml file is not broken.

Share this post


Link to post
Share on other sites

Thanks, Chris. config.xml is fine. I sent in an e-mail to support. The only result of the grep command is what I posted previously:

Sep 15 18:17:47 pidp8 pulseway[1119]: Illegal instruction

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Rave-Net Computers
      With MS Sql 2017 bringing official Linux server support for SUSE, Ubuntu, Redhat and others we really need the sql server module ported to Linux
    • By kmclaren
      I have a Ubuntu Linux machine that I have setup to monitor a number of network resources.  One of the things I want to do is pick a few locations across VPN's to look for any latency issues.  When I setup my config.xml with multiple servers, I only seem to look at the first server.  Here is an example (IP's changed to protect the innocent):
       
          <!--Network-->
          <Network>
              <!--Ping
            - Server: server IP address or hostname-->
              <Ping Server="1.2.3.1" Enabled="true"/>
              <Ping Server="1.2.3.2" Enabled="true"/>
              <Ping Server="1.2.3.3" Enabled="true"/>
              <Ping Server="1.2.3.4" Enabled="true"/>
       
      When I do this it appears that the ping time is the same as 1.2.3.1.  I know that 1.2.3.3 and 1.2.3.4 are a longer ping time.  So I turned off  1.2.3.1 and 1.2.3.2 like this:
          <!--Network-->
          <Network>
              <!--Ping
            - Server: server IP address or hostname-->
              <Ping Server="1.2.3.1" Enabled="false"/>
              <Ping Server="1.2.3.2" Enabled="false"/>
              <Ping Server="1.2.3.3" Enabled="true"/>
              <Ping Server="1.2.3.4" Enabled="true"/>
      If I do this I loose my Ping in my pulseway dashboard.  So I remove the first two lines and leave the following:
          <!--Network-->
          <Network>
              <!--Ping
            - Server: server IP address or hostname-->
              <Ping Server="1.2.3.3" Enabled="true"/>
              <Ping Server="1.2.3.4" Enabled="true"/>
      Now I see the longer ping time of 1.2.3.3.  Thus it appears that Pulseway only looks at the first ping statement.  Is this connect?  Does Pulseway only support one Ping?  If not, I may have found a bug.  Any help would be appreciated.
       
    • By themattman
      I have a Linux server with two attached USB drives.  In the monitor it has the correct paths for each respective drive.  However they are both reporting the same total drive space and free drive space for just one of the drives.  The other drive which is a different sized drive is not being reported correctly.  This happened about the time that the one drive that is not being reported correctly had a disconnect from the Linux server.  Do not know what happened but I rebooted the server and it found the drive no problem.  No issues with paths changing or anything.  But now the monitor has the wrong drive vitals.
       
      Update: I have disconnected the drive physically, and then reconnected it.  Also stopped and started the pulseway service while disconnected, then after reconnect.  And the same thing happened.  The drive reports the wrong size.  But, when I disconnected the drive that is reporting correctly (stopping and starting pulseway services) the drive that mis-reports moved up in the list, and is now reporting the wrong size from the internal drive (a 32GB SD card as this is an Odroid-XU4).  Still has the right path (/dev/sda1 and /mnt/usb_1) but reports the (/boot) path of 71MB.
    • By Lewnatick
      I recently installed the latest version of Pulseway on my Ubuntu 17.04 server. The service appears to be starting, and I'm not seeing any errors. However, the machine never shows up in the Pulseway app. I feel like I'm missing something simple here. Any advice would be greatly appreciated.
    • By comredit
      # rpm -i pulseway_x64.rpm
      error: Failed dependencies:
              rpmlib(PayloadIsLzma) <= 4.4.6-1 is needed by pulseway-5.1.2-1.x86_64
      # uname -m

      i686
      # cat /etc/redhat-release
      CentOS release 5.11 (Final)
       
       
      please advice asap ... 
       
       
×