Jump to content

Not running under Ubuntu 18.04


Akits
 Share

Recommended Posts

I'm having a similar problem after upgrading to Bionic Beaver (18.04) ... pulsewayd won't start. At first, after the upgrade, I was seeing this in the syslog:

Apr 26 19:38:34 nucleus pulseway[1006]: /usr/sbin/pulsewayd: error while loading shared libraries: libssl.so.0.9.8: cannot open shared object file: No such file or directory

So I downloaded the latest .deb and installed it over my existing install. pulsewayd still wouldn't start and now I'm seeing this:

Apr 26 21:19:52 nucleus pulseway[16794]: /usr/sbin/pulsewayd: symbol lookup error: /usr/sbin/pulsewayd: undefined symbol: CRYPTO_num_locks

But now when I try to start it nothing happens and nothing appears in the syslog.

 

Link to comment
Share on other sites

  • Staff

Hi,

Currently the Pulseway agent doesn't support the libssl version 1.1. You will need to do the following:

  1. Uninstall the Pulseway agent.
  2. Replace libssl 1.1 with libssl 1.0.2 or older versions of libssl.
  3. And finally, re-install the Pulseway agent.
Link to comment
Share on other sites

Any plans on supporting the newer libssl? This seems like the same problem that prevents Pulseway from running on my Raspberry Pi as well (link). That's been a problem since September last year and it still doesn't work. Very disappointing.

Link to comment
Share on other sites

I do have libssl 1.0.2 installed, by the way:

15:23:52 /usr/lib:$ dpkg -l |grep libssl
ii  libssl-dev:amd64                      1.1.0g-2ubuntu4                     amd64        Secure Sockets Layer toolkit - development files
ii  libssl1.0.0:amd64                     1.0.2n-1ubuntu5                     amd64        Secure Sockets Layer toolkit - shared libraries
ii  libssl1.1:amd64                       1.1.0g-2ubuntu4                     amd64        Secure Sockets Layer toolkit - shared libraries
15:28:58 /usr/lib/x86_64-linux-gnu:$ ls -la libssl*
-rw-r--r-- 1 root root 328128 Feb  5 05:36 libssl3.so
-rw-r--r-- 1 root root 740092 Apr 25 13:03 libssl.a
lrwxrwxrwx 1 root root     13 Apr 25 13:03 libssl.so -> libssl.so.1.1
-rw-r--r-- 1 root root 426232 Mar 27 13:48 libssl.so.1.0.0
-rw-r--r-- 1 root root 433760 Apr 25 13:03 libssl.so.1.1
15:30:23 /usr/lib/x86_64-linux-gnu:$ ls -la libcrypto*
-rw-r--r-- 1 root root 4832196 Apr 25 13:03 libcrypto.a
lrwxrwxrwx 1 root root      16 Apr 25 13:03 libcrypto.so -> libcrypto.so.1.1
-rw-r--r-- 1 root root 2357760 Mar 27 13:48 libcrypto.so.1.0.0
-rw-r--r-- 1 root root 2575848 Apr 25 13:03 libcrypto.so.1.1

 

Link to comment
Share on other sites

  • 2 weeks later...
On 5/15/2018 at 11:18 PM, Paul said:

Hi there,

You need to change the symbolic link to point to the 1.0.0 versions instead of the 1.1 versions.

-Paul

Any instructions on where to do this? Cant find any pointers on this...

Link to comment
Share on other sites

  • Administrators

Simply rename the old symbolic link using the:

Quote

mv oldFileName newFileName

command then create a new symbolic link using this command:

Quote

ln -s /path/to/file /path/to/symlink

-Paul

Link to comment
Share on other sites

  • 1 month later...
  • 4 weeks later...
  • 5 weeks later...

I finally got around to changing the libssl.so and libcrypto.ssl symlinks (to point to 1.0.0 versions of the files instead of 1.1) and the pulseway service started. It concerns me that maybe this could cause other security issues since I'm linking to older versions of the libraries, but I'll continue to monitor (heh) and see what happens.

Link to comment
Share on other sites

  • 1 month later...
  • 2 months later...
  • 3 weeks later...
  • 1 month later...
  • 1 month later...
  • 9 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Content

    • By Jamie Taylor
      Pulseway Client Portal now includes a built-in chat function that allows the end user to communicate directly with a technician. This can be started automatically as a step in a troubleshooter, or you can give users the option to start it directly themselves.   A summary of the chat is recorded and can be sent to the technician. Automation Workflows: Run assigned patch policy
      Start patching systems as they get added to Pulseway using the new Run Assigned Patch Policy action, now available for the System Registered workflow trigger.
      Remote Desktop Improvements
      Introducing Adaptive FPS to deliver the optimum resolution for the current network connection, resulting in an enhanced user experience.
       
    • By Jamie Taylor
      You can now trigger workflow executions from Performance Counter notifications and evaluate Name, Category and Instance in conditions to build even more customizable workflows for your IT processes.
    • By Jamie Taylor
      You can now create interactive, conditional troubleshooters that can be used to ask questions, provide answers, and run self remediation scripts and tasks based on user input. Pulseway's Client Portal can be used to standardize IT processes, empower end-users and reduce the workload on your support team.

       

       
    • By Leah96xxx
      I am trying to configure Pulseway on my Ubuntu Server 20.04 LTS machine, but I'm having issues getting it to recognise systemd services.
      The services I want to monitor are smbd, plexmediaserver and clamav-freshclam. Regardless of what configuration I use, none of these services are even recognised by Pulseway let alone monitored. I have also tried setting each service as "NONE", "UPSTART" and "SYSVINIT" but nothing seems to work.
      The strange part is that ssh is monitored despite the fact that it's configuration is identical to the others.
      Here is a screenshot of my configuration:
      Can someone please help me out here? Is there something I'm missing?
      EDIT: Never mind. It suddenly started working after I posted this.
    • By Astrofrite
      Hi, i want to know how i can monitor the dropbox daemon on linux, i'v tried things with workflow but when i stop the service manualy it won't send me a notification or try to restart the service, and that is bothering me becaus on our servers we need to have dropbox running all the time for our application, i know that dropbox is weird on linux, it won't show with systemctl, but it's still like a daemon.
      I'm running debian buster machine all up to date with the last pulseway agent
       
×
×
  • Create New...