Jump to content
Akits

Not running under Ubuntu 18.04

Recommended Posts

Hi

I can't get pulseway to connect to the android app when it's running on my ubuntu 18.04 server. It worked just fine until I updated to U 18.04.
Has this occured to any one else? Is there an solution?

Share this post


Link to post
Share on other sites

I'm having a similar problem after upgrading to Bionic Beaver (18.04) ... pulsewayd won't start. At first, after the upgrade, I was seeing this in the syslog:

Apr 26 19:38:34 nucleus pulseway[1006]: /usr/sbin/pulsewayd: error while loading shared libraries: libssl.so.0.9.8: cannot open shared object file: No such file or directory

So I downloaded the latest .deb and installed it over my existing install. pulsewayd still wouldn't start and now I'm seeing this:

Apr 26 21:19:52 nucleus pulseway[16794]: /usr/sbin/pulsewayd: symbol lookup error: /usr/sbin/pulsewayd: undefined symbol: CRYPTO_num_locks

But now when I try to start it nothing happens and nothing appears in the syslog.

 

Share this post


Link to post
Share on other sites

Hi,

Currently the Pulseway agent doesn't support the libssl version 1.1. You will need to do the following:

  1. Uninstall the Pulseway agent.
  2. Replace libssl 1.1 with libssl 1.0.2 or older versions of libssl.
  3. And finally, re-install the Pulseway agent.

Share this post


Link to post
Share on other sites

Any plans on supporting the newer libssl? This seems like the same problem that prevents Pulseway from running on my Raspberry Pi as well (link). That's been a problem since September last year and it still doesn't work. Very disappointing.

Share this post


Link to post
Share on other sites

I do have libssl 1.0.2 installed, by the way:

15:23:52 /usr/lib:$ dpkg -l |grep libssl
ii  libssl-dev:amd64                      1.1.0g-2ubuntu4                     amd64        Secure Sockets Layer toolkit - development files
ii  libssl1.0.0:amd64                     1.0.2n-1ubuntu5                     amd64        Secure Sockets Layer toolkit - shared libraries
ii  libssl1.1:amd64                       1.1.0g-2ubuntu4                     amd64        Secure Sockets Layer toolkit - shared libraries
15:28:58 /usr/lib/x86_64-linux-gnu:$ ls -la libssl*
-rw-r--r-- 1 root root 328128 Feb  5 05:36 libssl3.so
-rw-r--r-- 1 root root 740092 Apr 25 13:03 libssl.a
lrwxrwxrwx 1 root root     13 Apr 25 13:03 libssl.so -> libssl.so.1.1
-rw-r--r-- 1 root root 426232 Mar 27 13:48 libssl.so.1.0.0
-rw-r--r-- 1 root root 433760 Apr 25 13:03 libssl.so.1.1
15:30:23 /usr/lib/x86_64-linux-gnu:$ ls -la libcrypto*
-rw-r--r-- 1 root root 4832196 Apr 25 13:03 libcrypto.a
lrwxrwxrwx 1 root root      16 Apr 25 13:03 libcrypto.so -> libcrypto.so.1.1
-rw-r--r-- 1 root root 2357760 Mar 27 13:48 libcrypto.so.1.0.0
-rw-r--r-- 1 root root 2575848 Apr 25 13:03 libcrypto.so.1.1

 

Share this post


Link to post
Share on other sites

Hi there,

You need to change the symbolic link to point to the 1.0.0 versions instead of the 1.1 versions.

-Paul

Share this post


Link to post
Share on other sites
On 5/15/2018 at 11:18 PM, Paul said:

Hi there,

You need to change the symbolic link to point to the 1.0.0 versions instead of the 1.1 versions.

-Paul

Any instructions on where to do this? Cant find any pointers on this...

Share this post


Link to post
Share on other sites

Simply rename the old symbolic link using the:

Quote

mv oldFileName newFileName

command then create a new symbolic link using this command:

Quote

ln -s /path/to/file /path/to/symlink

-Paul

Share this post


Link to post
Share on other sites

I have two machines running bionic. On one the libraries keep re-St linking back to the 1.1 versions. Would appreciate knowledge no how to stop that happening.

Thanks

Share this post


Link to post
Share on other sites

I finally got around to changing the libssl.so and libcrypto.ssl symlinks (to point to 1.0.0 versions of the files instead of 1.1) and the pulseway service started. It concerns me that maybe this could cause other security issues since I'm linking to older versions of the libraries, but I'll continue to monitor (heh) and see what happens.

Share this post


Link to post
Share on other sites

I had to re-apply my symlink changes after upgrading to Ubuntu 18.10. So I'm still using the 1.0.0 versions of libssl.so and libcrypto.so to get Pulseway to run. Seems odd that switching to v1.1 wouldn't be on the roadmap.

Share this post


Link to post
Share on other sites
On 1/29/2019 at 8:35 AM, Manthey IT said:

Same problem here.

 

When will 6.1 be released?

Waiting for months now... going to contact official support to escalate.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Louwrens
      Please expand the list of programs on 3rd Party Patch management.
      Some suggestions:
      Adobe Flash
      Amazon Corretto (Since Oracle Java is not free anymore)
      Dropbox
      Gimp
      Google Gsync (GSuite)
      K-lite Codec
      LibreOffice
      OpenVPN
      Thunderbird
      WhatsApp Desktop Client
       
       
       
    • By XxLilBoPeepsxX
      I am attempting to install pulseway on my raspberry pi 3b+, and have downloaded and installed the correct file from the pulseway website, and made sure that my openssl libraries are up to date and correctly setup. I followed through with the given installation instructions and repeatedly the pulseway service is unable to be started. When executing the command sudo systemctl start pulseway, the command works and presents no errors. Upon checking the app or the list of all services, however, pulseway is not shown as a service and there is no devices connected to the app. See the attached images for the output of sudo systemctl status pulseway


    • By knis
      I installed Pulseway on Ubuntu 16.10   64 bit.   It was success.
      I want only monitor HDD and CPU usage and Power off computer.
      I want disable other features in config.xml.
      How can I disable (I see mobile app) Users, Terminal, Scripts, Enter Maintenance Mode?
      Thanks!
    • By pheald
      I am running CentOS 6 and I can track most of my /etc/init.d services just fine - except for iptables.  When the service is running, Pulseway reports that it is down.
      For example, these lines work just fine:
      <Service Name="ntpd" DisplayName="NTPD Service" IsDaemon="true" DaemonType="SYSVINIT" Path="" StartParameters="" CanBeStopped="true" Enabled="true"/> <Service Name="crond" DisplayName="Cron Daemon" IsDaemon="true" DaemonType="SYSVINIT" Path="" StartParameters="" CanBeStopped="true" Enabled="true"/> But this one does not
      <Service Name="iptables" DisplayName="iptables Service" IsDaemon="true" DaemonType="SYSVINIT" Path="" StartParameters="" CanBeStopped="true" Enabled="true"/> Does anyone have any ideas?  I'm relatively new to Pulseway so it is entirely possible that I'm just missing something obvious.
       
      Edit: I just confirmed that I can start the service successfully when I manually stop it, but it still never detects it as running.
    • By mark.vail
      after following this setup guild i am getting "-bash: /etc/init.d/pulseway: No such file or directory"
      looked inside that folder and did not see any pulseway scrips. is there another guild that i can follow that will be more helpful 

×
×
  • Create New...