Jump to content
SimonW

The agent failed to start rd session

Recommended Posts

Hello,

I first noticed this problem after performing a new install of agent 4.8.3 on an SBS 2011 server.   Capture.thumb.PNG.3e8593d3c33a63dbc6e4fe 

I thought it was related to just this Server (which has been rebooted since install and the firewall is disabled), but found that this error occurs with a number of Windows 7 hosts as well.  I can't immediately establish the reason why some hosts connect and others don't.

I've not encountered this error before so am unsure where to start with troubleshooting.

Appreciate any assistance.

Share this post


Link to post
Share on other sites

Hi,

Can you please check to see if the affected systems are running a 32-bit operating on a 64-bit supported processor?

Chris

Share this post


Link to post
Share on other sites

Do you mean a 32 Bit version of Pulseway Agent, or the OSE?

I have checked two of the systems that fail to connect (Windows Server 2008 and Windows 7) and both OSE are 64 bit.

I've just noticed that I am unable to connect to any host that is on an external network to our Enterprise Server.  (I'm definitely trying to Remote Desktop, not Microsoft Remote Desktop Connection)

Edited by SimonW

Share this post


Link to post
Share on other sites

Found the cause of my problem.  The Pulseway server was presented to the Internet via Windows Application Proxy, hence the public IP address of each host was that of the WAP server.

 

Share this post


Link to post
Share on other sites

Hi Ken,

Do you use a Proxy to connect to the Internet? If so, try adding *.pulseway.com and pulseway.com to the proxy direct access list.

Chris

Share this post


Link to post
Share on other sites

I am also running into this situation. We just upgraded our Server 2008 R2 64Bit to Server 2012 R2 64Bit to make use of the remote desktop function and tool. However when trying to connect to any device we have it setup for we get the error "The agent failed to start the rd session." 

Any help with this would be amazing.

We do not use a proxy. Our Pulseway server is located on AWS though.

Share this post


Link to post
Share on other sites

Hi Charles,

Would you be able to send an email to support [at] pulseway [dot] com? I'll get pick up your email once I see it.

-Paul

Share this post


Link to post
Share on other sites

I too am running an Enterprise server behind WAP.  Is there any fix for allowing remote desktop to work, when it thinks the clients are on the local network (thanks to WAP for masq the source IP)?

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By MrBuzz2u
      I am looking for a way to track windows user logins/logouts...but many users only lock/unlock their desktop rather than log out.  Any other way to track this and receive notifications?  If notifications are not possible, how about a report that would gather this info?  Hoping to do this through Pulseway, but open to other options/apps as well.   Any help would be greatly appreciated.
    • By MakoLogics
      Hello I keep getting a ton of alerts daily for Windows Defender, they show up as important updates. I run the Web Root AV on all my clients so I would love a script to disable Windows Defender on all machines. It would take for ever to do hundreds of machines manually.
       
      Thank you.
    • By MakoLogics
      Is there a way to change settings in each of the desktop clients via the web?
      See image below for example.
       
       

    • By itshero
      I am having trouble connecting to workstations via the dashboard, as well as the remote desktop application.  Getting error "The agent failed to start the rd session."
    • By cesarius
      Hello,
      since some days my hard disk drives don't spin down anymore while not in use. I tracked the problem down with process monitor and found out that the PCMonitor Service is accessing the drives every minute through the WMI Provider Host Service (wmiprvse.exe).
      I disabled in Pulseway the storage notification of local disk space on all drives but it did not help.
      As soon as I disable the Puleway service, the disks spin down after the configured laps of time as they should do.
      I'am using Pulseway since some years, but the problem occured recently and was not there before.
      Thanks for your help.
      Michael
       
×