Jump to content

Android App Remote Control - Can't Login To Remote PCs


Recommended Posts

I love the fact that we can now use the android app to remote into managed devices.  It works well when the user is already logged in...

The problem I'm experiencing is when I remote control a Windows device and have to login.  I bring up the keyboard no problem and try typing the password to that computer.  What I am typing on my keyboard isn't typing in the password box on the PC.  In other words, it never seems to respond and type the password letters as I am typing, hence I cannot login (invalid password).  I suspect it has something to do with how Android on Samsung deals with autofill.  Ironically, I don't have this problem when using the Team Viewer app on the same phone.  That fact leads me to believe that it is a problem with the Pulseway Android App.

Using a Samsung Galaxy Note 9 running Android 10.

Link to post
Share on other sites

Hi Chris,

It is somewhat hard to describe. Perhaps we can do a team viewer session into my phone so you can see it first hand.

I'm using a Samsung Galaxy Note 9, running Android 10.

The steps taken are:

1. Open the Pulseway Android app.

2. Drill down to one of the endpoints.

3. Tap "remote control."

4. Tap the available session.

5. Send Ctrl Alt Delete command of necessary.

6. Open the keyboard to type in the password.

This is where it is goofy.  As I am typing, the character count doesn't increase in the remote password box.  I can see the auto fill on the android keyboard populating, but it doesn't fill in on the host side...

I was finally able to login by typing the password, letting the autofill populate, tapping it to "send" it to the remote screen.  I noticed that the character count was one too many, so I had to highlight it and backspace once to delete the space that the autofill adds...

The problem is that the autofill has a mind of its own and will not always accept the password, or will try to break it up, so it is extremely unpredictable as to what it actually sends to the host password box.

This behaviour is also seen after finally logging in to the host...  When entering text into the host, I cannot get it to accept what I am typing without playing the "autofill game."

I call it autofill, but when I turned off the autofill in the Android keyboard, it did not help...

If it were an Andorid problem, I would experience the same thing when using other remote apps like chrome remote desktop or team viewer...

 

Kyle

Link to post
Share on other sites
  • 2 weeks later...

I'm getting suspicious about the keyboard-app being the culprit in this case, but I'm not an expert. 

 

I would at least consider using another keyboard app for a while to see if it behaves differently. I'm using Gboard on my OnePlus device and it works well with Pulseway Remote Control, another keyboard to consider might be "Switftkey" among others. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By crakpot
      I would really like to see an outlook add-in that can be pushed through office 365 to all users that would allow them to submit tickets with drop down menus for ticket type, sub-type, priority and description. 
       
    • By OnsiteITservices
      Using USB external hard drive as backup devices and each drive can be recognized if manually added to the notifications/storage screen but I need to know if there is a way to set this to be automatic when the drive is replaced either daily or weekly.  Also, where would this be set globally for are servers being monitored. Currently have 8.6.8.
       
      Thank you,
      Todd Kollars
      Onsite IT Services
    • By Canadian Dental Services
      Hi all,
      I recently did a clean upgrade to Windows 10 on 2 WKSTs previously running Windows 7 with Pulseway installed.  I am now at a loss as to how to re-add these units to my Pulseway instance.
      I see they are still showing up in the “Deployment Successful” tab under “Discovery & Deployment”.
      Is there a way to re-add these units without manually installing the Pulseway app on these WKSTs?
    • By RingTailedLemur7
      Hello, I have a question about the Pulseway app. When the pc is on all of the commands work great and are perfect for managing the pc. But I am attempting to turn on my pc when I am away from my home and then be able to fully control it like I was there. The issue is how the wake up command from sleep or from powered down will not work even when on my home network. How can I fix this. Also a side question, is there a way I would be able to see a live view of the screen or does it only allow screenshots of the screen. Thanks
    • By DQuiram
      We reinstalled Pulseway on a re-imaged system and after the install we noticed issues. In the patch mgmt section, the status was "assign failed" in red. We rebooted the system and then the service was not starting. We checked the service, it was set to start automatically and in the event log it was generating this error: "Service cannot be started.  The handle is invalid"  We removed the system from Pulseway, uninstalled, and reinstalled. Service is starting normally, but still getting the same issue of the patch policy failing to assign. I tried moving the system to another group that did not have a patch policy at all and got the same result. 
×
×
  • Create New...