Jump to content

Android App Remote Control - Can't Login To Remote PCs


Kyle
 Share

Recommended Posts

I love the fact that we can now use the android app to remote into managed devices.  It works well when the user is already logged in...

The problem I'm experiencing is when I remote control a Windows device and have to login.  I bring up the keyboard no problem and try typing the password to that computer.  What I am typing on my keyboard isn't typing in the password box on the PC.  In other words, it never seems to respond and type the password letters as I am typing, hence I cannot login (invalid password).  I suspect it has something to do with how Android on Samsung deals with autofill.  Ironically, I don't have this problem when using the Team Viewer app on the same phone.  That fact leads me to believe that it is a problem with the Pulseway Android App.

Using a Samsung Galaxy Note 9 running Android 10.

Link to comment
Share on other sites

Hi Chris,

It is somewhat hard to describe. Perhaps we can do a team viewer session into my phone so you can see it first hand.

I'm using a Samsung Galaxy Note 9, running Android 10.

The steps taken are:

1. Open the Pulseway Android app.

2. Drill down to one of the endpoints.

3. Tap "remote control."

4. Tap the available session.

5. Send Ctrl Alt Delete command of necessary.

6. Open the keyboard to type in the password.

This is where it is goofy.  As I am typing, the character count doesn't increase in the remote password box.  I can see the auto fill on the android keyboard populating, but it doesn't fill in on the host side...

I was finally able to login by typing the password, letting the autofill populate, tapping it to "send" it to the remote screen.  I noticed that the character count was one too many, so I had to highlight it and backspace once to delete the space that the autofill adds...

The problem is that the autofill has a mind of its own and will not always accept the password, or will try to break it up, so it is extremely unpredictable as to what it actually sends to the host password box.

This behaviour is also seen after finally logging in to the host...  When entering text into the host, I cannot get it to accept what I am typing without playing the "autofill game."

I call it autofill, but when I turned off the autofill in the Android keyboard, it did not help...

If it were an Andorid problem, I would experience the same thing when using other remote apps like chrome remote desktop or team viewer...

 

Kyle

Link to comment
Share on other sites

  • 2 weeks later...

I'm getting suspicious about the keyboard-app being the culprit in this case, but I'm not an expert. 

 

I would at least consider using another keyboard app for a while to see if it behaves differently. I'm using Gboard on my OnePlus device and it works well with Pulseway Remote Control, another keyboard to consider might be "Switftkey" among others. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...