Jump to content

Import Pulseway configuration from command line


Recommended Posts

  • Staff

In order to import a Pulseway configuration file you need to start PCMonitorManager (Pulseway Manager) from Pulseway's installation directory with the following parameters:

PCMonitorManager.exe /config=C:\Configuration\NoPassword.pcmcfg

If the exported configuration file contains the account details then you need to provided the configuration password as well:

PCMonitorManager.exe /config=C:\Configuration\WithPassword.pcmcfg /configpassword=s3cr3tpassw0rd

Note: The PCMonitorManager will not provide any console output or custom exit codes based to indicate the success of the operation.

Link to post
Share on other sites

I am not able to get this to work. I export the pcmcfg file via the Gui, then attempt a import. The Gui starts, and the settings aren't the same as the configuration file. My plan is to create a script via SCCM that automatically imports the saved configure as I have seen the settings disappear at random intervals. We are running the OnPrem solution and any help is appreciated.

Link to post
Share on other sites
  • 1 month later...

I have a script that dumps the config file from a central storage location to c:\temp. then runs this

 

 

"C:\Program Files\Pulseway\PCMonitorManager.exe" /config=c:\temp\Hyper-V2.pcmcfg /configpassword=(correctpassword)

 

this runs the program, but the settings are not imported, I reopen the console and my old settings are there, nothing changed.

 

I have tried manually running this from the local command prompt with administrator privileges and it still does not work.

 

I'm running version 4.7.6 Build 704

 

thoughts?

alternative ways of doing this?

I'm trying to load templates to 250 servers on my network and its not been going very well.

Link to post
Share on other sites
  • Staff

Hi,

 

Can you please create a configuration export with fake account information and export it with a password then PM me the configuration file and the configuration password and I will attempt to reproduce it.

 

Regards,

Chris

Pulseway Support

Link to post
Share on other sites
  • 2 months later...

Hi all,

Can anyone provide assistance on how to push a base configuration to all workstation clients via GPO or script?  I got the GPO to perform the Pulseway agent install and able to applied the MST so it can authenticate to our assigned enterprise server.  However, all the monitor and alert settings are default.

Any help is appreciated.

Edited by gate122
spelling error
Link to post
Share on other sites
  • Administrators

Hi,

You can centrally manage the configuration of multiple systems through Pulseway Group Policies (not GPOs) which can be created from Pulseway Manager -> Manage Systems -> Manage Group Policies. A Pulseway Group Policy will override the local configuration however it will not overwrite it so if you disable a setting from the policy then the local configuration will take effect.

You can also use GPOs to push registry patches which will work however it's a lot more work to be done. To import a registry file from command line simply run: regedit UNC_PATH\export.reg. Only overwrite the values you need.

Alternatively you can have agents import their configuration from a file using the command line switches as instructed on this topic.

Paul

Link to post
Share on other sites
  • 6 months later...
  • Staff

Hi,

Can you PM me your arguments and the configuration file? Does Pulseway Manager import the configuration file when attempting to do it from the UI? Are you invoking the PulsewayManager app with administrative rights?

Chris

Link to post
Share on other sites
  • 1 year later...

Does this still work on 6.0?

I can import the config via the UI but not via command line or during an unattended installation as I was doing with 5.x versions. Even though I was able to import a previous version configuration via the UI, I still tried exporting a configuration from a 6.0 install to make sure it wasn't a version compatibility issue.

Thanks.

Link to post
Share on other sites
  • 2 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By OnsiteITservices
      Using USB external hard drive as backup devices and each drive can be recognized if manually added to the notifications/storage screen but I need to know if there is a way to set this to be automatic when the drive is replaced either daily or weekly.  Also, where would this be set globally for are servers being monitored. Currently have 8.6.8.
       
      Thank you,
      Todd Kollars
      Onsite IT Services
    • By Leah96xxx
      I am trying to configure Pulseway on my Ubuntu Server 20.04 LTS machine, but I'm having issues getting it to recognise systemd services.
      The services I want to monitor are smbd, plexmediaserver and clamav-freshclam. Regardless of what configuration I use, none of these services are even recognised by Pulseway let alone monitored. I have also tried setting each service as "NONE", "UPSTART" and "SYSVINIT" but nothing seems to work.
      The strange part is that ssh is monitored despite the fact that it's configuration is identical to the others.
      Here is a screenshot of my configuration:
      Can someone please help me out here? Is there something I'm missing?
      EDIT: Never mind. It suddenly started working after I posted this.
    • By Astrofrite
      Hi, i want to know how i can monitor the dropbox daemon on linux, i'v tried things with workflow but when i stop the service manualy it won't send me a notification or try to restart the service, and that is bothering me becaus on our servers we need to have dropbox running all the time for our application, i know that dropbox is weird on linux, it won't show with systemctl, but it's still like a daemon.
      I'm running debian buster machine all up to date with the last pulseway agent
       
    • By Cilusse
      Hello there,
      I was in the process of configuring my Pulseway agent on a VPS running Ubuntu Server 20.04 and I ran in this interesting bug.
      Even using the sample config provided by the agent, uncommenting the Ping Responses bloc throws this error in the log, and prevents the service from starting.
      vps pulseway: Starting Pulseway Daemon version 6.5 (2019082205) vps pulseway: Configuration: Values for 'Milliseconds' attribute at 'PingResponse' node 10.6.0.53(1) should be between 1 and 1000 vps systemd: pulseway.service: Main process exited, code=exited, status=1/FAILURE  
      The PingResponse bloc in /etc/pulseway/config.xml looks like this:
      <PingResponses> <PingResponse Address="10.6.0.53" Milliseconds="1500" Minutes="1" PriorityOnSlowResponse="1" PriorityOnNoResponse="1" Alias="vps DNS notif" Enabled="true"/> </PingResponses>  
      So then I tried many Milliseconds values between 1 and 1000 but the same exact error always comes back.
      Is this a known issue or is there anything wrong with my setup?
       
      Many thanks to anyone who can help,
      Best,
    • By Jason Corlett
      Can anyone find the new in 8.5 feature "Network Monitoring" or know how to add a device?
×
×
  • Create New...