Jump to content

Recommended Posts

  • Administrators

Hi there,

For the Pulseway 3rd party patching system to work you need to provide it with an MSI file, not an executable bootstrapper. MSIs enforce a certain standard that allows us to identify if the application is already installed and perform the installation or removal without any user interaction.

-Paul

Link to post
Share on other sites
  • Administrators
5 minutes ago, kylorenisntdead said:

I too have the same issue but i am using an MSI. have tried Sharepoint, icloud, drop box. etx

Hi there,

I've checked your custom software titles and it seems that UC-ONE was successfully provisioned and Test has failed to provision because the iCloud link you've provided is not a direct link to the file so our provisioning system is receiving HTML text instead of the MSI file.

-Paul

Link to post
Share on other sites
  • Administrators
10 hours ago, kylorenisntdead said:

Can you please provide more information on why this is happening. here is the link

I've removed the link for your security. Basically iCloud and most other file sharing websites try to hide direct links to the files in order to prevent the spread of malware and to prevent abuse of their service. That being said, you do want to be able to download files without any user interaction on the site so you should host these files on a publicly accessible web server that you control, AWS S3 or a similar file hosting service which allows you to directly access the file and not a landing page which then links to the actual file.

-Paul

Link to post
Share on other sites
  • 3 weeks later...
  • 5 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By DQuiram
      We reinstalled Pulseway on a re-imaged system and after the install we noticed issues. In the patch mgmt section, the status was "assign failed" in red. We rebooted the system and then the service was not starting. We checked the service, it was set to start automatically and in the event log it was generating this error: "Service cannot be started.  The handle is invalid"  We removed the system from Pulseway, uninstalled, and reinstalled. Service is starting normally, but still getting the same issue of the patch policy failing to assign. I tried moving the system to another group that did not have a patch policy at all and got the same result. 
    • By Brant
      I've implemented a script that retrieves and stores the Windows Build Version number to a custom field in the system overview.   It works fine on MOST systems.  However, there are a small number systems that are unable to run the script.  The error message displayed includes: Start-Process : This command cannot be run due to the error: The system cannot find the file specified.
      I used the "Insert Output Variable Code" in the script and verified that it includes the inserted text "Start-Process -FilePath "$env:PWY_HOME\CLI.exe" -ArgumentList ("setVariable  .....".
      For some reason, a few systems do not seem to have the environment variable PWY_HOME set.
      It appears that these systems are using the Enable PowerShell User Impersonation option under Pulseway Manger > Settings > Runtime.
      What is the easiest way to make sure that all of my systems have the PWY_HOME variable set so that any future scripts will not fail because of a missing environment variable?
      Thanks,
      Brant
    • By devansh.gohil
      I had installed Pulseway and then wanted to delete it but I was not able to find Pulseway in the control panel uninstall feature and so I tried manually uninstalling files but that also did not work. I tried running the .msi installer again but an error came up saying that Pulseway is already installed but it still was not showing up. Please help me with this.
    • By ArrowNM
      A Dark Mode option for both the RMM Web UI and PSA UI would be nice.
    • By Bob | PTI B.V.
      Hi all,
      Do anyone of you have a script to remove Solarwinds products? In our case, that should be the N-able Windows agent and Solarwinds MSP (SolarWinds MSP Cache Service, SolarWinds MSP Patch Management Engine, SolarWinds MSP RPC Server). Or have any experience removing it using automation?
      Thanks in advance!
       
×
×
  • Create New...