Jump to content

Custom Titles


Sean Faria
 Share

Recommended Posts

  • Administrators

Hi there,

For the Pulseway 3rd party patching system to work you need to provide it with an MSI file, not an executable bootstrapper. MSIs enforce a certain standard that allows us to identify if the application is already installed and perform the installation or removal without any user interaction.

-Paul

Link to comment
Share on other sites

  • Administrators
5 minutes ago, kylorenisntdead said:

I too have the same issue but i am using an MSI. have tried Sharepoint, icloud, drop box. etx

Hi there,

I've checked your custom software titles and it seems that UC-ONE was successfully provisioned and Test has failed to provision because the iCloud link you've provided is not a direct link to the file so our provisioning system is receiving HTML text instead of the MSI file.

-Paul

Link to comment
Share on other sites

  • Administrators
10 hours ago, kylorenisntdead said:

Can you please provide more information on why this is happening. here is the link

I've removed the link for your security. Basically iCloud and most other file sharing websites try to hide direct links to the files in order to prevent the spread of malware and to prevent abuse of their service. That being said, you do want to be able to download files without any user interaction on the site so you should host these files on a publicly accessible web server that you control, AWS S3 or a similar file hosting service which allows you to directly access the file and not a landing page which then links to the actual file.

-Paul

Link to comment
Share on other sites

  • 3 weeks later...
  • Administrators

Hi @Scott1987,

It appears that the link is redirecting to another page and our package collector doesn't handle redirects yet (we'll add it soon). In the meantime feel free to use the actual download link of the file: https://swupdate.openvpn.net/beta-downloads/connect/openvpn-connect-3.1.3.713_signed.msi.

-Paul

Link to comment
Share on other sites

  • 5 months later...
  • 6 months later...

I've been able to successfully add a custom title (in this case, Splashtop Business MSI deployment). However, when applying to a patch policy and configuring to install and keep up to date then custom title never gets installed. I will mention that at this point I've only manually run the policy but that has never seemed to matter.

Link to comment
Share on other sites

  • 4 weeks later...
  • 7 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...