Jump to content
sesipod

Installing linux agent on Debian 9.4 ( proxmox VE 5.2-1 )

Recommended Posts

When installing the pulseway agent on my Debian Version 9.4 X64 proxmox VE 5.2-1 server I get the following. 

I have restarted the server 3 times now after each install attempt - I can't figure out where the log is located.

An error occurred while starting Pulseway service. Please see log for more details.

Here is the steps that I did to get started...

root@Dell-R610:~# wget https://www.pulseway.com/download/pulseway_x64.deb

root@Dell-R610:~# dpkg -i pulseway_x64.deb

root@Dell-R610:~# pulseway-registration

Would you like to register or unregister the system?

[1] Register System
[2] Exit

Enter selection: 1

Please enter a username: ********
Please enter the password: *******
Use custom server? [y|n] n

1 organization found. Please select the organization

[1] sesinet

Enter selection: 1

1 site found. Please select the site

[1] sesinet_site

Enter selection: 1

1 agent group found. Please select the agent group

[1] sesinet

Enter selection: 1

Check if the config.xml exist ...
Configuration file not found.
Check if the config.xml.sample exist ...
Create a new config.xml file based on config.xml.sample
New config.xml successfully created.

Update the configuration file...

Config file updated successfully!

Do you want to start Pulseway service? [y|n] y

An error occurred while starting Pulseway service. Please see log for more details.

I also tried to make the config file myself. Replacing it with the one form ( https://my.pulseway.com/main/setup/guide ) 

Share this post


Link to post
Share on other sites

Hi,

Logs can be checked with the  journalctl utility. Alternatively you can try to check the status of the daemon via systemctl status pulseway.service

Mark

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Tim Roewen
      Hi there,
      We are using both PSA and RMM from Pulseway.
      In the last few weeks we are experiencing some weird behavior between PSA and RMM.
      We don't use the and never set up the integration, but after we delete the settings both in PSA and RMM, it still comes back.
      It is irritating us enormously and the support isn't helpful after creating several tickets.
      I hope someone can help us with this issue.
      King regards,
      Tim Roewen
       
    • By Hax4dayz
      Ok so the other day i got informed about pulseway by linus tech tips and it seemed a good idea for me to install it on my raspberry pi vpn server for monitoring. But a few days after that my sd card died and i decided to start from scratch and make a new vpn + install pulseway again. But now i cant get the pi to show up at all.
      I installed everything as this post described but cant get it to show up. I did try to search the problem on google but nothing i tired helped.
      My raspberry pi model is the 3b
       
    • By frooky
      I would very much like to see some Arch Linux scripts added or at least include Arch compatibility in the existing Linux scripts. Updating my Arch systems from my phone with a single click would be pretty slick.
    • By remotenerd
      I have installed Pulseway on my unraid server and it has ben working great. I can monitor everything and shutdown/restart the machine. However,  wake on lan is not working at all. I have enabled it in the BIOS and in the OS. I can wake the machine using my router, but not with the Pulseway app. In the config.xml file I have WoWAN set to true and the port to 9 (also tried 50000) and it still doesn't work. Is there something I am missing?
      P.S. I also have a Windows machine that has WOW working perfectly.
      Thank you for your help.
×