Jump to content

Operation refused as the account has 2FA enabled - options?


David Richmond
 Share

Recommended Posts

Hey all! Testing out Pulseway's REST API endpoints. I can query for systems, etc but executing a task just gets a happy little 403...

Posting to: https://api.pulseway.com/v2/automation/tasks/[redacted]/executions returns this:

{
    "meta": {
        "response_code": 403,
        "error_message": "Operation refused as the account has 2FA enabled."
    },
    "data": {
        "id": 0
    }
}
 
What recourse do I have here? Is the REST API simply unavailable for task execution in cloud accounts while 2FA is enabled? Suppose I could disable it and just live with a super-long password, but... perhaps there is a way :)
 
Thanks!
Link to comment
Share on other sites

  • 2 weeks later...
On 1/17/2022 at 10:09 AM, Paul said:

Hi David,

We are in the process of introducing API keys which will allow executing tasks for accounts with 2FA. In the meantime you can disable 2FA and use a long password or wait for the API changes.

-Paul

 

Sorry for hijacking the thread, but do you know if IT-Glue will allow integrations with this method once you guys have introduced it to Pulseway?

That's the only thing preventing me from clicking the "Enforce MFA" button in Pulseway as it's currently configured with username+pass.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...