Jump to content

CentOS - Invalid Username found in configuration


Truty
 Share

Recommended Posts

As the title goes I just can't get it to authenticate my username.

---------------------------------------------------------------------------------------------------

 pulseway.service - LSB: start and stop pulsewayd
   Loaded: loaded (/etc/rc.d/init.d/pulseway; bad; vendor preset: disabled)
   Active: active (exited) since Sun 2018-09-30 16:56:59 CEST; 53s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 16999 ExecStop=/etc/rc.d/init.d/pulseway stop (code=exited, status=0/SUCCESS)
  Process: 17053 ExecStart=/etc/rc.d/init.d/pulseway start (code=exited, status=0/SUCCESS)

Sep 30 16:56:59 plexserver systemd[1]: Starting LSB: start and stop pulsewayd...
Sep 30 16:56:59 plexserver pulseway[17062]: Configuration: Invalid Username found in configuration
Sep 30 16:56:59 plexserver pulseway[17053]: Starting pulseway daemon: [  OK  ]
Sep 30 16:56:59 plexserver systemd[1]: Started LSB: start and stop pulsewayd.
--------------------

Editing /etc/pulseway/config.xml in so many ways I have no idea what is wrong.  

------------------------------------------------------------------------------------------------------

<!--Account Information
    - Username: testuser
    - Password: mypassword
    - UseCustomServer: enable this option only if you have a dedicated Enterprise Server assigned to your account
    - CustomServerAddress: your Enterprise Server address-->
  <Account Username="" Password="" UseCustomServer="false" CustomServerAddress="" />

--------------------------------------------------------------------------------------------------------------------

Except for the fields username and password, I didn't change anything in the configuration file. 
 

I installed the agent on my Windows PC just to test it worked with no problems, now that I am trying to install the same thing on CentOS I get invalid username in configuration. Am I failing in formatting that the username should be written in the configuration file?

 

Link to comment
Share on other sites

  • Staff

Hi Truty,

Quote

<!--Account Information
    - Username: testuser
    - Password: mypassword
    - UseCustomServer: enable this option only if you have a dedicated Enterprise Server assigned to your account
    - CustomServerAddress: your Enterprise Server address-->
  <Account Username="username_here" Password="password_here" UseCustomServer="false" CustomServerAddress="" />

The line starting with "<!--" it's a xml comment. Please replace the "username_here" and the "password_here" with your credentials.

Mark

 

Link to comment
Share on other sites

  • 3 weeks later...

hi I already change as your guide but the log still show the invalid username

Oct 16 19:31:12 localhost pulseway: Configuration: Invalid Username found in configuration
Oct 16 19:33:48 localhost pulseway: Configuration: Invalid Username found in configuration
Oct 16 19:33:54 localhost pulseway: Configuration: Invalid Username found in configuration
 

 

here my configuration and please advice

<?xml version="1.0" encoding="utf-8"?>
<config xmlns="http://www.pulseway.com/linuxconfig">
  <!--Pulseway Linux Monitoring Agent - pulseway.com -->

  <!--Account Information
    - Username: root
    - Password: rootroot
    - UseCustomServer: enable this option only if you have a dedicated Enterprise Server assigned to your account
    - CustomServerAddress: your Enterprise Server address-->
  <Account Username="root" Password="rootroot" UseCustomServer="false" CustomServerAddress="" />
 

Link to comment
Share on other sites

  • Administrators

You only need to change this line:

 <Account Username="root" Password="rootroot" UseCustomServer="false" CustomServerAddress="" />

Replace root with your Pulseway username and replace rootroot with your Pulseway password and then restart the Pulseway daemon using this command:

sudo service pulseway restart

-Paul

Link to comment
Share on other sites

hi Paul,

 

it seem the configuration is success but still get another error. could you please assist

Oct 17 15:26:05 testing-agent pulseway: Configuration read successfully!
Oct 17 15:26:05 testing-agent pulseway: Could not get server info SOAP 1.1 fault SOAP-ENV:Server[no subcode]#012"Try Again"#012Detail: get host by name failed in tcp_connect()
 

Link to comment
Share on other sites

Same problem;  tons of:
"Error while registering computer:SOAP 1.1 fault SOAP-ENV:Server[no subcode]#012"Try Again"#012Detail: get host by name failed in tcp_connect()"
in my logfile.

===

dig ws0.pulseway.com

; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.68.rc1.el6_10.1 <<>> ws0.pulseway.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 5223
;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;ws0.pulseway.com.        IN    A

;; ANSWER SECTION:
ws0.pulseway.com.    14464    IN    CNAME    lb.pulseway.com.
lb.pulseway.com.    14464    IN    A    69.65.47.165
lb.pulseway.com.    14464    IN    A    69.65.47.163

;; Query time: 19 msec
;; SERVER: 10.22.2.254#53(10.22.2.254)
;; WHEN: Tue Oct 23 12:21:49 2018
;; MSG SIZE  rcvd: 83

===

 

Edited by Teletubbi-OSX
Link to comment
Share on other sites

  • Staff

Hi,

According to the screenshot we can see that the server-name is resolved, but for some reason you are not allowed to connect to this instance. Please check the firewall rules which might block these connections or web filer rules which could block these connections.

Also you might try to use the curl to get the response from the our server: https://ws0.pulseway.com/Server.svc

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...