Jump to content

Can't uninstall PC Monitor


itshero
 Share

Recommended Posts

Hello,

I was having an issue install the Kaspersky Anti-Virus on a machine, and decided to try uninstalling Pulseway from the system.  I uninstalled the program, and deleted the service using the sc delete "PC Monitor" command under an administrator account.  The issue I am having, is the re-installation fails, and hangs on the "scheduled tasks" portion of the initialization wizard (the part before the pc monitor panel comes up).  After the installer crashes, it still shows the application as "installed" for the user, and most things work on the machine. (remote desktop does not from the pulseway dashboard).  The installation also does not show up in programs and features.  

OS is Windows 7 64 bit, and user is on a domain, and has local administrator.  

Is there anything I can do other than reformatting the user PC to get a genuine clean install so I can use the product we are paying for?

 

Thanks.

Link to comment
Share on other sites

  • Staff

Hi,

You can try to uninstall the Pulseway Manager and delete the configuration using this PowerShell script. But note that if the Pulseway agent is installed only for one user, then you will need to configure the PowerShell impersonation from the Pulseway Manager -> Settings -> Runtime and then run this script.

 

try
{
  $app = gwmi win32_product | Where-Object {$_.name -match "Pulseway"}
  $app.Uninstall()
  Remove-Item -Path "HKLM:\SOFTWARE\MMSOFT Design" -Recurse
  Write-Host "Uninstallation completed successfully"
}
Catch
{
  $ErrorMessage = $_.Exception.Message
  $FailedItem = $_.Exception.ItemName
  Write-Host "There was an error on $computername.`r`n$FailedItem`r`nMessage: $ErrorMessage"
  Break
}

 

Link to comment
Share on other sites

  • 2 years later...

I am having the same issue. Why can't I simply find it in my programs and features and uninstall it? I tried the powershell script above and it said it successfully uninstalled it. But Pulseway manager is still there.

I originally had a personal account and downloaded the agent on my work computer. Then I started the 14-day trial for team accounts and needed to reinstall the agent on that same machine but it keeps giving me an error 1001 code "This service already exists".

I simply just need to reinstall the agent but this seems difficult to do normally. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...