Jump to content
SyntechCS

Service not starting on reboot

Recommended Posts

Just wondering if anyone else has noticed this issue recently.

Yesterday I installed Pulseway on 4 computers, installed and activated fine but after a restart they all showed offline and when I checked them the Pulseway service hadn't started. After an hour or so reinstalling and disabling other start-up apps I found that the only way to get it to start on a reboot was to set the service to Automatic-delayed start. This is obviously not a specific computer issue as it occurred on 4 different machines all installed one after the other, the only similarity is that they're all running Windows 10. I suppose it's possible that a recent Windows update or even a Pulseway update has caused some kind of issue but I was wanting to check if anyone else had experienced this? I have another 40+ machines to install and don't want to have to mess around having the manually change the service properties on every one of them.

Share this post


Link to post
Share on other sites

Hi there,

We've noticed that this can happen of machines that are under heavy load during startup. A better solution would be to increase the service start timeout to 2 minutes.

Quote

 

1. Click Start, click Run, type regedit, and then click OK.
2. Locate and then click the following registry subkey:
 - HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control
3. In the right pane, locate the ServicesPipeTimeout entry.

**Note**: If the ServicesPipeTimeout entry does not exist, you must create it. To do this, follow these steps:

 - On the Edit menu, point to New, and then click DWORD Value.
 - Type ServicesPipeTimeout, and then press ENTER. 
4. Right-click ServicesPipeTimeout, and then click Modify.
5. Click Decimal, type 120000, and then click OK.
 - This value represents the time in milliseconds before a service times out.
6. Restart the computer.

 

-Paul

Share this post


Link to post
Share on other sites

A better solution would be to find the registry entry that details whether the service starts normally or delayed, and export it after changing it to delayed.

I already addressed this:

It should be an option on install.  I have the same issue and I am not unique.

Share this post


Link to post
Share on other sites

I am aware of the delayed start option although I didn't really consider exporting the registry entry which would speed up the process of changing the service start type. Maybe it would be better if Pulseway were designed to start delayed by default. Yes it would mean a 1-2 minute delay in being able to reconnect to a machine after reboot but I'd prefer that than to find I can no longer access a server after a restart when doing maintenance. Currently I'm having to install Teamviewer alongside Pulseway as this allows me to see immediately when a machine comes back online.

Share this post


Link to post
Share on other sites
Quote
On 2/20/2017 at 5:44 AM, Paul said:

Hi there,

We've noticed that this can happen of machines that are under heavy load during startup. A better solution would be to increase the service start timeout to 2 minutes.

-Paul

Would it be possible to come up with a script we could use to merge this fix into the registry? It seems like the latest Windows updates are breaking the connections.

 

Share this post


Link to post
Share on other sites
17 hours ago, pablohoney said:

Would it be possible to come up with a script we could use to merge this fix into the registry? It seems like the latest Windows updates are breaking the connections.

There is a built-in script called "Increase Windows Service Timeout at Startup" that performs this change.

-Paul

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...