Jump to content

Windows 8 App just displaying blank screen

Recommended Posts

I have downloaded and installed the Windows 8 metro app to have a look at but when I run it it shows the splash screen "PC Monitor" and just displays a blank screen. I can call the Charms menu up and even if I do "About" it doesn't display anything at all. Other links in the Charms menu ie "Terms Of service" call up IE and "Request a Feature" jumps to email. Any ideas? Regards Mark

Link to post
Share on other sites
  • 2 weeks later...

Further to this I have updated the app per the notification in the Windows Store, it still displays a blank dark blue page but when I moved my mouse around the screen it changed to the cursor icon in two areas, I assumed these were the credentials boxes so I blindly entered in my details and pressed Enter. The screen still shows a dark blue blank page but I got a notification via email that I had added a new device to my account so I assume then that the issue is something graphical? I don't have any other display issues in anything else I use but I am using multiple monitors. Any further ideas?

Link to post
Share on other sites

I had the same issue -- blank app except for charms, but notifications worked perfectly. Unfortunately, I can not remember how I fixed it. For some reason, I am thinking it was a routing issue. Not sure, though. If it comes back to me, I will edit this post.

Link to post
Share on other sites

Have exactly the same problem :( Just a blank screen, and in the sidebar no preview.. Can't logon because it displays nothing.. Thing is, it's only on my work-Win8 notebook.. My home win8 notebook has no issues with this.. Though that's a Intel GMA950 device, where at work I'm with a Radeon HD2600.. 


So the weird thing: It worked in the past. Somehow this bevaviour has popped up. Still get messages, but can't actually open the app. When I uninstall the app, and reinstall, the settings are retained! Still getting messages and everything, but same behaviour.. 


When I uninstall the app, it's also removed from %ProgramFiles%\WindowsApps so no cached info there.. There are remnants in the registry, but they address merely notification history, icons etc.. Just to be safe I removed them too.. %appdata%\local\Packages also did nolonger contain information about PC Monitor.. Cleared all temp folders, restarted, ran CCleaner. Also found two extra entries of "MMSOFTDesign" in my %appdata%\local\Microsoft\Windows\Live\Roaming\LocalCache folder. I figured these are the settings from Metro apps which are synced to the cloud to sync the app settings across different Win8 machines. Deleted them too for good measure. 


Still no luck. Darn. 


Colleague of mine said that roaming cache of your live account is only deleted after 30 days of 'inactivity', which means that if the app is deleted from all your Win8 devices, only after 30 days the roaming cached data is deleted.. 

Perhaps I'm missing something, but can anyone shed any light on this? Of perhaps Matt can suddenly remember what the solution was and help us all :)

Link to post
Share on other sites
  • Administrators

I am in the same boat...  the app used to work on my Win8 pc beautifully, now I get a blue screen, and it maxes out one of my processors.  It is like there is some loop it gets stuck in.


I have uninstall/reinstalled, etc...


I am willing to help in any way to get this resolved. I am a developer myself, if you need someone to run a debug version, etc. please let me know.


Dan Gentry

dan at greater visions dot com

Link to post
Share on other sites

it was not the only app that experienced the issue. 


I had updated my video drivers, but had not rebooted (so I apologize now for not doing that BEFORE I posted..). So I rebooted.. when I rebooted Windows said "reboot and update" so apparently there was an outstanding Windows update.


anywho, it is now working again..  thank goodness!


for reference, I did see the splash screen, and the live tile was updating.

Link to post
Share on other sites
  • 3 weeks later...

Further to this I had Windows 8 running in Bootcamp on my Mac Book pro so installed the app on here and it worked fine.


Today I have installed the newest NVidia drivers on my PC so have gone from 306.97 to 310.70 and now the application is working fine.


I guess its fairly safe to assume that the problem is related to graphics drivers and that hopefully the issue is resolved as drivers are updated. 

Link to post
Share on other sites
  • 2 years later...

Sounds like you might need to do a fresh install. I just had to do one last night on my laptop because of a DNS issue in Win8. Refresh and Reset didn't seem to solve it, so I had no choice. That's why his is a beta though.

Could try using the Repair options available on the Windows 8 disk (click Repair your Computer, instead of Install) before resorting to wiping it out completely though.

Good luck!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...