Jump to content

No notification when service is "active (excited)"


Aaron Trujillo
 Share

Recommended Posts

We recently noticed a problem with our Pulseway notifications, on one of our Linux servers that is running Cassandra.  The Cassandra service had been put into the following state:  Active: active (excited), unfortunately we never received notification about the excited state.  I did some testing and when I manually stop the service, it shows Active: inactive (dead), I do get notifications.  I am at a lose as to why I get notifications when inactive (dead) but not when it is Active (excited).

This is the current configuration:

<Service Name="cassandra" DisplayName="cassandra" IsDaemon="true" DaemonType="SYSTEMD" Path="" StartParameters="" CanBeStopped="true" Enabled="true" />

If I change DaemonType to any other setting:  NONE, SYSVINIT, or UPSTART, the service will not be recognized at all by Pulseway.  So I am fairly confident that SYSTEMD is the correct parameter here.  What is the correct way to set this up, so that I get notifications when its dead and/or excited?

Thank you for your help.

Link to comment
Share on other sites

  • Staff

Hi Aarron,

You always can check the current status for the monitored service from your mobile device or from the Pulseway WebApp. Currently Pulseway sends the notification only if the service is stopped. But if you want to receive the notification if the service is started, then you will need to use the Pulseway REST API to send this notification from your system.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...