Jump to content

Automations / Tasks do not run at scheduled time.


steve1673
 Share

Recommended Posts

I've been trying to automate as many of my maintenance tasks as possible with Pulseway, but I've noticed that the scheduled start time does not correspond with the actual start time. It's not consistent though, so it doesn't appear to be a time zone issue. Here's some examples:

Sample: Cleanup Temporary Files
Weekly on Thursday starting on 29 December 2016 at 20:00

image
16 February 2017 21:39
Took 8 seconds
Result: Successful
image
15 February 2017 20:00
Took 15 seconds
Result: Successful
image
8 February 2017 20:00
Took 15 seconds
Result: Successful
image
1 February 2017 20:00
Took 22 seconds
Result: Successful
image
25 January 2017 20:00
Took 1 minute and 42 seconds
Result: Successful
image
18 January 2017 20:00
Took 18 seconds
Result: Successful
image
12 January 2017 22:06
Took 1 minute and 3 seconds
Result: Successful
image
11 January 2017 20:00
Took 20 seconds
Result: Successful
image
4 January 2017 23:56
Took 10 seconds
Result: Successful
 
Other tasks have the same issue with scheduling. While basic maintenance scripts like time syncs, temp file cleanup are not time sensitive, Other tasks are. I have my complete weekly patch and update sequence saved as scheduled tasks, and I can't use it because the scripts are not guaranteed to run during my maintenance window. 
Any ideas?
Link to comment
Share on other sites

  • Administrators

Hi Steve,

This appears to be a timezone issue after all. Our engineers are working on it as we speak to resolve it. In the meantime you can change the schedule type to daily and have it repeat every 7 days:

2017-02-24_16-22-57.png.3056310ff6d7c38dc8027fb646e580df.png

-Paul

Link to comment
Share on other sites

  • 3 weeks later...

Changing the schedule to daily did work, up until this week. It's now 15 minutes past the expected start time of the scripts and nothing has happened. (verified in the execution history). At this point I'm not sure if this is going to kick off sometime unexpected, so I'm going to need to disable scheduling again. 

Is this an issue with the DST change? Perhaps we should move everything to UTC? :) 

Link to comment
Share on other sites

  • 1 year later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...