Jump to content

PC Monitor locks files


mzenhorst
 Share

Recommended Posts

I'm running PC Monitor and all is well.

Except for the fact that it seems to be locking files at OS level.

Mainly when I'm running my VirtualBox image with a raw disk I get the following error:

Failed to open image: '<filename>' for writing due to wrong permissions (ERR_VD_IMAGE_READ_ONLY).

 

I have found that disabling the PC Monitor service will let me start the VirtualBox image correctly.

I have tried this several times.

 

Therefore I can only conclude that PC Monitor is blocking the write mode.

However I'm not sure whether it is the vmdk file or the physical disk itself that is locked by PC Monitor.

I'm suspecting the physical drive since creating the vmdk file failed with a sharing exception (VERR_SHARING_VIOLATION) until I disabled the PC Monitor service

 

I hope you can help me by explaining why PC Monitor is locking files?

 

Kind regards,

Mark Zenhorst

Link to comment
Share on other sites

Hello,

 

I tried the unlocker and I did the following case:

 

Start PC monitor service

Then start VM, failed with:

Failed to open a session for the virtual machine OXX.

Failed to open image 'D:\OXX\OXXShared.vmdk' for writing due to wrong permissions (VERR_VD_IMAGE_READ_ONLY).

Failed to attach driver below us! Image is read-only. (VERR_VD_IMAGE_READ_ONLY).

AHCI: Failed to attach drive to Port1 (VERR_VD_IMAGE_READ_ONLY).

Result Code: E_FAIL (0x80004005) Component: Console Interface: IConsole {db7ab4ca-2a3f-4183-9243-c1208da92392}

 

The unlocker does not show any locking handles.

However this only happens when I start the PC Monitor service before I start the VM. Otherwise it will start normally.

 

 

System: Windows XP Professional version 2002 SP3 (build 5.1.2600)

vmdk file is a raw device file, it points to PhysicalDisk0.

 

How could I further debug this?

Link to comment
Share on other sites

  • Administrators

Hello,

 

If unlocker is not showing any locking handles then you have something else that's part of your operating system or applications. I use PC Monitor with Virtual Box on Microsoft Windows Server 2008 R2 and on Ubuntu 12.10 with no problems. I believe this is an isolated case. Can you reproduce the same problem on another machine?

 

Paul.

Link to comment
Share on other sites

I have no issues with normal virtualbox disks, just with rawdisks.

It looks then if the device is not allowing write access for some reason.

 

Unfortunately I cannot reproduce on a different computer, hence I think this will not get resolved.

 

I'll work around it by starting the vm from a service and depend PC Monitor on it.

If PC Monitor is started while vbox is running no error is thrown during restarts of the vm.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...