Jump to content
cjs1976

Pulseway service doesn't start correct on some systems.

Recommended Posts

Hi,

on a couple of systems the Pulseway Agent doesn’t start automatically. If I look into the services.msc I see that the service should start automatically, but it doesn’t. In the moment when I start the Pulseway Manager, I get an information, and I can start the Pulseway Agent. I am also able to start the agent over the services.msc.

Any idea?

Thanks,
Christian.

Share this post


Link to post
Share on other sites

Hi @IT Vigilante - This is a common issue. This topic (registry fix) helped me: 

Hopefully they'll fix this in the next release.

Edited by pablohoney

Share this post


Link to post
Share on other sites

hi pablohoney,

thank you for this information. I read also the linked contents. I knew allready the possibility of the delayed start, and this is what I did on the machines which have the problem.

But this is a strange behavior, and I am not happy to use the delayed start or any other special tuning. I want to install Pulseway and it should work.

I belive, that this systems (nearly 10% of the monitored devices) have a problem, and I want to find out what it is, so that I can fix it.

Thanks,
Christian.

Share this post


Link to post
Share on other sites

Hi Christian,

There is also a built-in script that will double the service timeout time called 'Increase Windows Service Timeout at Startup'. We've seen this happening on systems that are running low on resources during boot and it's .NET Framework that fails to initialize on time thus Service Control Manager kills the whole service.

-Paul

Share this post


Link to post
Share on other sites

Other RMM tools, like LabTech deal with this issue by having a 2nd service that watches the 1st service ad makes sure it is running. Have you guys considered something like that with Pulseway?

Share this post


Link to post
Share on other sites

We now set every machine to delayed start but sorting this really needs to be a priority, it's a pain when you need to restart a machine during a remote support call with a customer and then  have to either wait up to 5 minutes for it to come back online before you can reconnect, or if the customer's present you need to talk them through starting the service manually. We've now started using Comodo One for the remote control element as they don't seem to suffer from the same issue and machines come back online within 1-2 minutes.

Share this post


Link to post
Share on other sites

Hi,

Currently, we are using this solution:

At first please have a look into the Windows event log, to find out why the Pulseway service fails to start (look for the entry from Service ControlManager), if the error is that service did not respond to start or control request in a timely manner, then the first thing that you can try is to configure the Pulseway service start as Automatic(Delayed Start) and/or recovery options. But If that doesn't help, then you can try to increase the startup timeout by running built-in script 'Increase Windows Service Timeout at Startup' (You can adjust the timeout interval. In this script it is set to 60000ms [60 seconds]). Our customers get the best results if the timeout interval is set to 90000 (90 seconds).

In order to run this script on multiple machines at once, you will need to create an automated task. Please read more about this from here.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...