Jump to content

There was no endpoint listening at...

Recommended Posts


after installing Pulseway Agent on a Server I got following message when registering the machine:


There was no endpoint listening at https://ourcompany.pulseway.com/Server.svc ......


There are other servers in the network where the installation did work without any problem. I have set proxy settings, without any success.

I already uninstalled, rebooted and checked if a firewall blocks the traffic. no changes...


Any hints on that?

Thanks and regards



Share this post

Link to post
Share on other sites


This message usually is shown if the Pulseway agent can not connect to the Pulseway server or if the server which it is connecting to is not the Pulseway server. Please check the basic thinks:

1.  Can you resolve the DNS name correctly? nslookup ourcompany.pulseway.com

2. Can you ping your Pulseway instance?

3. Try to use the tracert command to identify where the connection drops?

4. Try to open https://ourcompany.pulseway.com/Server.svc using the Internet explorer? Any errors?

5. Also check if the Pulseway network traffic is excluded from the Web content filter, because it is encrypted and Web content will not be able to read it, therefore it will be blocked.

Share this post

Link to post
Share on other sites

Hi Chris,

thanks for your reply.

1. Resolving worked

2. Pink is OK

3. Tracert took a while but worked

4. No errors, message returned by browser looks like shown below

This is a Windows© Communication Foundation service.

Metadata publishing for this service is currently disabled.

If you have access to the service, you can enable metadata publishing by completing the following steps to modify your web or application configuration file:

1. Create the following service behavior configuration, or add the <serviceMetadata> element to an existing service behavior configuration:

5. Pulseway works in the same network in different VLANs without any issues. Same firewall configuration is used in different locations and pulseway works on all except on that machine. I can't change anything on the proxy as it is no maintained by us. Turned off local firewall services on the machine as well, but that didn't help.





Share this post

Link to post
Share on other sites


If there are systems in the same VLAN which can connect to the Pulseway and there are no specific network Rules (ACLs) in place which might block these connections, then try the following:

Reset WINSOCK entries to installation defaults :

netsh winsock reset catalog

Reset TCP/IP stack to installation defaults :

netsh int ip reset reset.log

Flush DNS resolver cache :

ipconfig /flushdns

Renew DNS client registration and refresh DHCP leases :

ipconfig /registerdns

Flush routing table :

route /f
(reboot required)



Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...