Jump to content

Implementation is not part of the Windows Platform FIPS


Brian L
 Share

Recommended Posts

Able to install Pulseway no problem, but we do get the following error when we try and register/validate the account:
This implementation is not part of the Windows Platform FIPS validated cryptographic algorithms.

FIPS is enabled on these systems and we do have the .NET reg key to force TLS 1.2 pushed out using GP.

Any help would be appreciated.

Thanks.

Screen Shot 2019-01-10 at 11.34.10 AM.png

Forgot to mention using Pulseway version 6.1.1

UPDATE.

Actually figured out a work around.

Had to add the following to pcmonitormanager.exe.config, pcmonitorsrv.exe.config, and pulsewayaddonmanager.exe.config:
<configuration>                                                           
    <runtime>
        <!-- below tag will disable security policy checking for FIPS -->
        <enforceFIPSPolicy enabled="false"/>
    </runtime>
</configuration>

Not sure which file edit actually fixed it, but it let me register the device and start the service.

Link to comment
Share on other sites

  • 2 weeks later...
  • Staff

Hi @Brian L ,

When you install the Pulseway agent on the remote system, then we automatically create the registry key which enables the TLS 1.2 for the .Net framework 4.0.

Regarding the editing the config files - yes it is correct, you need to edit all 3 of these files.

Thank you for sharing this. I will ask our development team to consider the possibility to add this into the config files by default.

Alternatively if you will disable the FIPS policy then it will work too.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...