Jump to content
Paul

Migrate your agents from Professional to Team

Recommended Posts

First, configure a windows agent with an account on the Team plan and validate the account to make sure the credentials are correct. Apply the configuration and write down the values of the following registry entries:

  • AuthenticationToken
  • AuthenticationTokenCtrl

Now go to the WebApp on the professional server (link), login and go to the Automation -> Scripts view. Select (or create) a category and click on the Create Script button. Enter a script name and under Windows tab, enable the script and select PowerShell as the script type then paste the following script:

Set-ItemProperty -Path "HKLM:\Software\MMSOFT Design\PC Monitor\" -Name AuthenticationToken -Value "Enter the saved AccountPassword from the machine you've just configured"
Set-ItemProperty -Path "HKLM:\Software\MMSOFT Design\PC Monitor\" -Name AuthenticationTokenCtrl -Value "Enter the saved AccountPasswordCtrl from the machine you've just configured"

Replace the values of AuthenticationToken and AuthenticationTokenCtrl to the values you've wrote down from the agent you've configured to connect to the Enterprise server


Skip this step if you don't have any Linux agents configured. If you have, then you will need to configure one of your Linux agents to use your new Pulseway server and then you will need to copy the following line from the config.xml file from the Linux system which is configured to use your new server.

<Account Username="" Password="" UseCustomServer="false" CustomServerAddress="" Token=""/>

And then Under the Linux tab, enable the script and paste in the following script using the values from the line which you have copied previously:

sed -i 's/\t<Account.*/\t<Account Username="" Password="" UseCustomServer="false" CustomServerAddress="" Token=""\/>/' /etc/pulseway/config.xml
/etc/init.d/pulseway restart


Save the task and then run it. Please note that the task will stop automatically in 15 minutes but the systems get moved right away. This is happening because you've moved the agents to a new Pulseway server and the SaaS Professional servers stop hearing back from your agents and will mark the systems as unresponsive in the task execution after 15 to 30 minutes of inactivity.
 
Warning: Please note that if you make any mistakes in the values or break the xml configuration layout by removing a closing quote the agents will stop and you will have to manually reconfigure them. It is recommended that you create a system scope that only includes one system so that you can test that the migration script contains the correct values.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...