Jump to content

Can't link server with Pulseway


cross
 Share

Recommended Posts

Hey,

 

I use PCmonitor, I mean now is Pulseway (terrible name btw :P) for 2 years ? More less. I had only one time configure config and it was on fedora 17 , config of PCmonitor. I had to make clean install of Fedora 20 so it's about time to reinstall old PCmonitor to pulseway. So I did. It should be easy but.. I quess it's not. I configure whole config, add username and password usually stuff, started the service systemctl start pulseway.service chkconfig pulseway on .. and? Nothing. I don't see my computer in my account any of my smartphone.. what could be the problem?

 

Link to comment
Share on other sites

  • Staff

Hi,

I just install it on a fresh Fedora 20 and everything works as expected.
Please check your log for any possible error or your config file.

Regards,
Mark

[root@localhost ~]# uname -a
Linux localhost.localdomain 3.11.10-301.fc20.x86_64 #1 SMP Thu Dec 5 14:01:17 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
[root@localhost ~]# cat /etc/issue
Fedora release 20 (Heisenbug)
Kernel \r on an \m (\l)

[root@localhost ~]#

[root@localhost ~]# rpm -ihv pulseway-4.4.3-1.x86_64.rpm
Preparing...                          ################################# [100%]
Stopping pulseway service
done
Updating / installing...
   1:pulseway-4.4.3-1                 ################################# [100%]

[root@localhost ~]# systemctl start pulseway.service

[root@localhost ~]# systemctl status pulseway.service
pulseway.service - LSB: start and stop pulsewayd
   Loaded: loaded (/etc/rc.d/init.d/pulseway)
   Active: active (running) since Thu 2014-07-31 21:46:34 IST; 20s ago
  Process: 2289 ExecStop=/etc/rc.d/init.d/pulseway stop (code=exited, status=0/SUCCESS)
  Process: 2733 ExecStart=/etc/rc.d/init.d/pulseway start (code=exited, status=0/SUCCESS)
  CGroup: /system.slice/pulseway.service
           2738 /usr/sbin/pulsewayd

Jul 31 21:46:34 localhost.localdomain pulseway[2733]: Starting pulseway daemo...
Jul 31 21:46:34 localhost.localdomain systemd[1]: Started LSB: start and stop...
Hint: Some lines were ellipsized, use -l to show in full.

[root@localhost ~]# ps auxww|grep '[p]ulsewayd'
root      3295  0.2  0.5 360032  5224 ?        Ssl  21:48   0:00 /usr/sbin/pulsewayd
[root@localhost ~]#

 

Link to comment
Share on other sites

You have on forum database issue I want to paste the log and It won't Post here.. 

 
This is all I can't paste and it's saves here.
 
[root@sonic Maildir]# ps auxww|grep '[p]ulsewayd'
[root@sonic Maildir]#
Link to comment
Share on other sites

I did. Here is log provide by fpaste service. I forgot I can use it too : http://ur1.ca/hw09y

 

Ok fixed / There was problem with Monitoring Service section. I deleted few of them and Now it works :)

 

But I can understand why in ssh section of monitored service I made 

 

 

<Service Name="ssh" DisplayName="SSH Daemon" IsDaemon="true" DaemonType="UPSTART" Path="/usr/sbin/sshd" StartParameters="systemctl start sshd.service" CanBeStopped="true" Enabled="true"/>

<Service Name="ntpd" DisplayName="NTPD Process" IsDaemon="false" DaemonType="NONE" Path="/usr/sbin/ntpd" StartParameters="-p /var/run/ntp/ntpd.pid -g -u ntp:ntp -i /var/lib/ntp -c /etc/ntp.conf" CanBeStopped="true" Enabled="false"/>

 

I gave ISDaemon cus SSHD is a Deamon and  gave parameter that CanBeStopped and in pulseway it shows only "start" option. Can't be stopped ?

 

Please give some  Tags in config explaination because I'm doing like in the examples and in MonitoreService section I can write properly tag for ssh service monitoring.

 

I have something like this: sie 01 22:33:39 sonic pulseway[27138]: Configuration: Value for 'Name' attribute 'Service' node is invalid

Link to comment
Share on other sites

  • Staff

Hi,

 

Correct configuration for sshd service on Fedora is:

 

<Service Name="sshd.service" DisplayName="SSH Daemon" IsDaemon="true" DaemonType="SYSTEMD" Path="" StartParameters="" CanBeStopped="true" Enabled="true"/>

 

Regards,

Mark

Link to comment
Share on other sites

I know that but what are for the other services? Cuz I manage to write them correctly (I think) and the pulseway haven't started. :/

Why Is Deamon Type systemd? That's why there should be a manual for that

Link to comment
Share on other sites

  • Staff

Hi,

 

Pulseway comming with a sample configuration file (/etc/pulseway/config.xml.sample). Please check http://forum.pulseway.com/topic/1219-sample-configxml/

You'll find there, under MonitoredServices tag, every parameter explained plus some examples:

<MonitoredServices>
<!--Name: Service name-->
<!--DisplayName: Friendly Display Name-->
<!--IsDaemon: 'true' or 'false'. 'true' if the monitored service is a daemon and 'false' if the monitored service is a process-->
<!--DaemonType: System Management daemon type: NONE or SYSVINIT or UPSTART or SYSTEMD-->
<!--Path: The path of the monitored service. This is used when the monitored service is a process-->
<!--StartParameters: Parameters used to start the monitored service. This is used when the monitored service is a process-->
<!--CanBeStopped: 'true' or 'false'-->
<!--Enabled: 'true' or 'false'-->
<Service Name="cups" DisplayName="CUPS Service" IsDaemon="true" DaemonType="SYSVINIT" Path="" StartParameters="" CanBeStopped="true" Enabled="false"/>
<Service Name="ssh" DisplayName="SSH Daemon" IsDaemon="true" DaemonType="UPSTART" Path="" StartParameters="" CanBeStopped="true" Enabled="false"/>
<Service Name="SuSEfirewall2.service" DisplayName="SuSE Firewall Service" IsDaemon="true" DaemonType="SYSTEMD" Path="" StartParameters="" CanBeStopped="true" Enabled="false"/>
<Service Name="ntpd" DisplayName="NTPD Process" IsDaemon="false" DaemonType="NONE" Path="/usr/sbin/ntpd" StartParameters="-p /var/run/ntp/ntpd.pid -g -u ntp:ntp -i /var/lib/ntp -c /etc/ntp.conf" CanBeStopped="true" Enabled="false"/>
</MonitoredServices>

Regards,

Mark

Link to comment
Share on other sites

I saw that example. But it doesn't explains why in few section is for example Path="" without any fields what does it mean that DaemonType is UPSTART SYSVINIT or Systemd. Not all services are configure the same. For example I started ntpd like in the example above And pulseway won't start, the same issue like before. So not always is like that

Link to comment
Share on other sites

  • 3 weeks later...
  • Administrators

As far as I remember NTP is still not converted to UPSTART for the Ubuntu distro so you have to use SYSVINIT as DaemonType. The Path of the NTP daemon is: /usr/sbin/ntpd.

 

Paul

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...