Jump to content

Pulseway offline in Web UI, online on client PC


Recommended Posts

We are having issues with a single Pulseway agent and I need help troubleshooting it. 

We have 2 servers installed in this environment, the first Server Pulseway works without fault, however on the second server Pulseway worked briefly, however now appears to be offline in the web client.

Connecting to the server and the service is running, agent is running, and registered.

I can successfully unregister and reregister the agent.

The trace.log file is below, it appears to run, and then close out with the following message:

pcmontask invoked in session '1' exited with error code '0'
And 5 seconds later:
Collecting computer information...

Any ideas on what the issue could be? The servers are installed at a clients site, so I don't have complete visibility on what networking/filtering existing in-between, however as it works on one server, and not the other it has me confused.

Thanks in advance

Simon

1/03/2021, 16:08:20.750: [Service] Service is stopping...
1/03/2021, 16:08:20.759: [Service] [Module Downloader] Closed
1/03/2021, 16:08:20.769: [Service] Stopping local clients (1)...
1/03/2021, 16:08:21.472: [Service] Stopping local server...
1/03/2021, 16:08:21.480: [Service] Local server stopped.
1/03/2021, 16:08:21.488: [Service] Shutting down automation task runner...
1/03/2021, 16:08:21.492: [Service] Automation task runner has stopped.
1/03/2021, 16:08:21.494: [Service] Shutting down automation ad-hoc script runner...
1/03/2021, 16:08:21.497: [Service] Automation ad-hoc script runner has stopped.
1/03/2021, 16:08:21.506: [AddonManagerWatchdog] Shutting down...
1/03/2021, 16:08:21.508: [AddonManagerWatchdog] Stopping...
1/03/2021, 16:08:21.511: [Service] Service stopped.
1/03/2021, 16:08:22.346: [Service] Pulseway Service ver. 8.6.1 build 112 is starting...
1/03/2021, 16:08:22.349: [Service] Copyright (C) 2021 MMSOFT Design Ltd. All rights reserved.
1/03/2021, 16:08:22.353: [Service] Increasing process priority to AboveNormal...
1/03/2021, 16:08:22.627: [Service] Using server address: NAME.pulseway.com
1/03/2021, 16:08:22.634: [Service] Setting service failure actions...
1/03/2021, 16:08:22.638: [Service] Service failure actions set.
1/03/2021, 16:08:22.641: [Service] Removing the operations task...
1/03/2021, 16:08:22.644: [Service] Operations task was removed successfully.
1/03/2021, 16:08:22.646: [Service] Service started.
1/03/2021, 16:08:22.647: [Service] Starting local server...
1/03/2021, 16:08:22.708: [Service] Local server started.
1/03/2021, 16:08:22.743: [Service] Starting pcmontask in session: '1'...
1/03/2021, 16:08:22.772: [Service] pcmontask invoked in session '1' exited with error code '0'
1/03/2021, 16:08:27.635: [Service] Collecting computer information...
1/03/2021, 16:12:18.182: [Service] Service is stopping...
1/03/2021, 16:12:18.197: [Service] [Module Downloader] Closed
1/03/2021, 16:12:18.213: [Service] Stopping local clients (1)...
1/03/2021, 16:12:18.916: [Service] Stopping local server...
1/03/2021, 16:12:18.916: [Service] Local server stopped.
1/03/2021, 16:12:18.916: [Service] Shutting down automation task runner...
1/03/2021, 16:12:18.932: [Service] Automation task runner has stopped.
1/03/2021, 16:12:18.932: [Service] Shutting down automation ad-hoc script runner...
1/03/2021, 16:12:18.932: [Service] Automation ad-hoc script runner has stopped.
1/03/2021, 16:12:18.947: [AddonManagerWatchdog] Shutting down...
1/03/2021, 16:12:18.947: [AddonManagerWatchdog] Stopping...
1/03/2021, 16:12:18.947: [Service] Service stopped.
1/03/2021, 16:12:19.775: [Service] Pulseway Service ver. 8.6.1 build 112 is starting...
1/03/2021, 16:12:19.775: [Service] Copyright (C) 2021 MMSOFT Design Ltd. All rights reserved.
1/03/2021, 16:12:19.791: [Service] Increasing process priority to AboveNormal...
1/03/2021, 16:12:20.041: [Service] Using server address: NAME.pulseway.com
1/03/2021, 16:12:20.057: [Service] Setting service failure actions...
1/03/2021, 16:12:20.057: [Service] Service failure actions set.
1/03/2021, 16:12:20.057: [Service] Removing the operations task...
1/03/2021, 16:12:20.057: [Service] Operations task was removed successfully.
1/03/2021, 16:12:20.057: [Service] Service started.
1/03/2021, 16:12:20.072: [Service] Starting local server...
1/03/2021, 16:12:20.119: [Service] Local server started.
1/03/2021, 16:12:20.166: [Service] Starting pcmontask in session: '1'...
1/03/2021, 16:12:20.182: [Service] pcmontask invoked in session '1' exited with error code '0'
1/03/2021, 16:12:25.056: [Service] Collecting computer information...

 

Edited by simong
Link to post
Share on other sites
  • 4 weeks later...

This one has self resolved. I'm not sure what exactly triggered it, a few reboots, a few more reinstallations. But one thing I think assisted was a new MSI.  I was using a preconfigured agent installation for a specific Org/Site/AgentGroup. I used a different link and it worked!

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...