Jump to content
matifudokan

I can't get pulseway to start on raspberry pi 3

Recommended Posts

I followed all the steps like instructed. I filled up the config. file with my username and password and saved it. When i try to start pulseway without "sudo" comand it shows:

==== AUTHENTICATING FOR org.freedesktop.systemd1.manage-unit-files ===
Authentication is required to manage system service or unit files.
Authenticating as: root
Password:


I tried my pi account password, my pulseway password and just leaving the password empty. After that i got:

==== AUTHENTICATION FAILED ===
Failed to enable unit: Access

 

So i tried to start pulseway with "sudo" and it seems like nothing happend.
When i checked the logs i got:

● pulseway.service - Remotely Monitor and Control IT Systems
   Loaded: loaded (/etc/systemd/system/pulseway.service; enabled; vendor preset: enabled)
   Active: inactive (dead) since Tue 2020-01-07 07:47:36 GMT; 7s ago
  Process: 5538 ExecStart=/usr/sbin/pulsewayd --no-daemonize (code=exited, status=15)
 Main PID: 5538 (code=exited, status=15)
    Tasks: 0 (limit: 2200)
   Memory: 7.7M
   CGroup: /system.slice/pulseway.service

Jan 07 07:47:32 Serwer systemd[1]: Started Remotely Monitor and Control IT Systems.
Jan 07 07:47:32 Serwer pulseway[5538]: Starting Pulseway Daemon version 6.5 (2019082205)
Jan 07 07:47:32 Serwer pulseway[5538]: Configuration read successfully!
Jan 07 07:47:33 Serwer pulseway[5538]: [383B blob data]
Jan 07 07:47:33 Serwer pulseway[5538]: [395B blob data]
Jan 07 07:47:34 Serwer pulseway[5538]: [389B blob data]
Jan 07 07:47:36 Serwer pulseway[5538]: Received request Stop monitoring service 'Invalid username and/or password (295).'
Jan 07 07:47:36 Serwer systemd[1]: pulseway.service: Succeeded.
Jan 07 07:47:36 Serwer pulsewayd[5538]: cut: write error: Broken pipe

 

I'm 100% sure that i have put my username and password correctly (Password got encrypted in the config file) The only thing i can think of is the fact that my password uses a polish symbol in it and that is creating problems.
 

I'm not very well-versed linux user so i'm just lost here. Can someone help?

 

Share this post


Link to post
Share on other sites

Hi,

You don't need to fill the config.xml with username/password. As is specified at the end of the installation, in order to register the agent please run the:

pulseway-registration

as root. This will register the agent and update the config.xml file for you.

Mark

Share this post


Link to post
Share on other sites
10 hours ago, Mark said:

Hi,

You don't need to fill the config.xml with username/password. As is specified at the end of the installation, in order to register the agent please run the:


pulseway-registration

as root. This will register the agent and update the config.xml file for you.

Mark

I got: An error encountered while processing the request. Please check the logs.
 

Share this post


Link to post
Share on other sites

Hi @matifudokan,

The error is related to config.xml. If you will leave config.xml file intact and use that executable pulseway-registration to register your system, then you will not receive that error.

Jan 07 07:47:36 Serwer pulseway[5538]: Received request Stop monitoring service 'Invalid username and/or password (295).'

Share this post


Link to post
Share on other sites

So i deleted everything i have put into config.xml but when i try to registrate it goes like this:

pi@Serwer:~ $ sudo pulseway-registration

Would you like to register or unregister the system?

[1] Register System
[2] Exit

Enter selection: 1

Please enter a username: matifudokan
Please enter the password:
Use custom server? [y|n] n

An error encountered while processing the request. Please check the logs.

 

Share this post


Link to post
Share on other sites

This?

Jan 15 14:17:12 Serwer pulseway: Starting Pulseway Daemon version 6.5 (201908220                                                                                                                                                             5)
Jan 15 14:17:12 Serwer pulseway: Configuration: Invalid Username found in config                                                                                                                                                             uration
Jan 15 14:17:12 Serwer systemd[1]: pulseway.service: Main process exited, code=e                                                                                                                                                             xited, status=1/FAILURE
Jan 15 14:17:12 Serwer systemd[1]: pulseway.service: Failed with result 'exit-co                                                                                                                                                             de'.
Jan 15 15:14:28 Serwer pulseway-registration: Connection error: ERROR_CODE:12, E                                                                                                                                                             RROR_MESSAGE: SOAP 1.1 fault SOAP-ENV:Server[no subcode]#012"System.Web.Services                                                                                                                                                             .Protocols.SoapException: Server was unable to process request. ---> MM.Monitor.                                                                                                                                                             WebService.InvalidAccountException: Invalid username and/or password (295).#015#                                                                                                                                                             012   at MM.Monitor.WebService.Data.#002(Account #002, String #003, String #005,                                                                                                                                                              String #010, String #006, Boolean #016, String #017, Boolean #002"#012Detail: [                                                                                                                                                             no detail]#012

Or this?

Jan 15 14:17:11 Serwer systemd[1]: Started Remotely Monitor and Control IT Systems.
Jan 15 14:17:12 Serwer pulseway[822]: Starting Pulseway Daemon version 6.5 (2019082205)
Jan 15 14:17:12 Serwer pulseway[822]: Configuration: Invalid Username found in configuration
Jan 15 14:17:12 Serwer systemd[1]: pulseway.service: Main process exited, code=exited, status=1/FAILURE
Jan 15 14:17:12 Serwer systemd[1]: pulseway.service: Failed with result 'exit-code'.

 

Edited by matifudokan

Share this post


Link to post
Share on other sites

Please delete the file /etc/pulseway/config.xml

rm /etc/pulseway/config.xml

And then run pulseway-registration

 

Share this post


Link to post
Share on other sites

I have deleted the config.xml  and got tha same "An error encountered while processing the request. Please check the logs.". After checking the status i got this:

● pulseway.service - Remotely Monitor and Control IT Systems
   Loaded: loaded (/etc/systemd/system/pulseway.service; enabled; vendor preset:
   Active: failed (Result: exit-code) since Wed 2020-01-15 14:17:12 GMT; 24h ago
 Main PID: 822 (code=exited, status=1/FAILURE)

Jan 15 14:17:11 Serwer systemd[1]: Started Remotely Monitor and Control IT Syste
Jan 15 14:17:12 Serwer pulseway[822]: Starting Pulseway Daemon version 6.5 (2019
Jan 15 14:17:12 Serwer pulseway[822]: Configuration: Invalid Username found in c
Jan 15 14:17:12 Serwer systemd[1]: pulseway.service: Main process exited, code=e
Jan 15 14:17:12 Serwer systemd[1]: pulseway.service: Failed with result 'exit-co

 

Edited by matifudokan

Share this post


Link to post
Share on other sites

Ok. So i reinstalled pulseway from the scratch. After running pulseway-registration it failed again and the logs showed:

Jan 23 12:28:22 Serwer pulseway-registration: Connection error: ERROR_CODE:12, E                                                                                                                                                             RROR_MESSAGE: SOAP 1.1 fault SOAP-ENV:Server[no subcode]#012"System.Web.Services                                                                                                                                                             .Protocols.SoapException: Server was unable to process request. ---> MM.Monitor.                                                                                                                                                             WebService.InvalidAccountException: Invalid username and/or password (295).#015#                                                                                                                                                             012   at MM.Monitor.WebService.Data.#002(Account #002, String #003, String #005,                                                                                                                                                              String #010, String #006, Boolean #016, String #017, Boolean #002"#012Detail: [                                                                                                                                                             no detail]#012

 

Share this post


Link to post
Share on other sites
1 hour ago, Chris said:

Hi @matifudokan,

Please verify that you can access the Pulseway server from that system:

curl https://s1.pulseway.com/Server.svc

I got:

pi@Serwer:~ $ curl https://s1.pulseway.com/Server.svc
<HTML><HEAD><STYLE type="text/css">#content{ FONT-SIZE: 0.7em; PADDING-BOTTOM: 2                                                                                                                                                             em; MARGIN-LEFT: 30px}BODY{MARGIN-TOP: 0px; MARGIN-LEFT: 0px; COLOR: #000000; FO                                                                                                                                                             NT-FAMILY: Verdana; BACKGROUND-COLOR: white}P{MARGIN-TOP: 0px; MARGIN-BOTTOM: 12                                                                                                                                                             px; COLOR: #000000; FONT-FAMILY: Verdana}PRE{BORDER-RIGHT: #f0f0e0 1px solid; PA                                                                                                                                                             DDING-RIGHT: 5px; BORDER-TOP: #f0f0e0 1px solid; MARGIN-TOP: -5px; PADDING-LEFT:                                                                                                                                                              5px; FONT-SIZE: 1.2em; PADDING-BOTTOM: 5px; BORDER-LEFT: #f0f0e0 1px solid; PAD                                                                                                                                                             DING-TOP: 5px; BORDER-BOTTOM: #f0f0e0 1px solid; FONT-FAMILY: Courier New; BACKG                                                                                                                                                             ROUND-COLOR: #e5e5cc}.heading1{MARGIN-TOP: 0px; PADDING-LEFT: 15px; FONT-WEIGHT:                                                                                                                                                              normal; FONT-SIZE: 26px; MARGIN-BOTTOM: 0px; PADDING-BOTTOM: 3px; MARGIN-LEFT:                                                                                                                                                              -30px; WIDTH: 100%; COLOR: #ffffff; PADDING-TOP: 10px; FONT-FAMILY: Tahoma; BACK                                                                                                                                                             GROUND-COLOR: #003366}.intro{MARGIN-LEFT: -15px}</STYLE>
<TITLE>Service</TITLE></HEAD><BODY>
<DIV id="content">
<P class="heading1">Service</P>
<BR/>
<P class="intro">This is a Windows&#169; Communication Foundation service.<BR/><                                                                                                                                                             BR/><B>Metadata publishing for this service is currently disabled.</B><BR/><BR/>                                                                                                                                                             If you have access to the service, you can enable metadata publishing by complet                                                                                                                                                             ing the following steps to modify your web or application configuration file:<BR                                                                                                                                                             /><BR/>1. Create the following service behavior configuration, or add the &lt;se                                                                                                                                                             rviceMetadata&gt; element to an existing service behavior configuration:</P>
<PRE>
<font color="blue">&lt;<font color="darkred">behaviors</font>&gt;</font>
<font color="blue">    &lt;<font color="darkred">serviceBehaviors</font>&gt;</fo                                                                                                                                                             nt>
<font color="blue">        &lt;<font color="darkred">behavior </font><font color                                                                                                                                                             ="red">name</font>=<font color="black">"</font>MyServiceTypeBehaviors<font color                                                                                                                                                             ="black">" </font>&gt;</font>
<font color="blue">            &lt;<font color="darkred">serviceMetadata </font>                                                                                                                                                             <font color="red">httpGetEnabled</font>=<font color="black">"</font>true<font co                                                                                                                                                             lor="black">" </font>/&gt;</font>
<font color="blue">        &lt;<font color="darkred">/behavior</font>&gt;</font>
<font color="blue">    &lt;<font color="darkred">/serviceBehaviors</font>&gt;</f                                                                                                                                                             ont>
<font color="blue">&lt;<font color="darkred">/behaviors</font>&gt;</font>
</PRE>
<P class="intro">2. Add the behavior configuration to the service:</P>
<PRE>
<font color="blue">&lt;<font color="darkred">service </font><font color="red">na                                                                                                                                                             me</font>=<font color="black">"</font><i>MyNamespace.MyServiceType</i><font colo                                                                                                                                                             r="black">" </font><font color="red">behaviorConfiguration</font>=<font color="b                                                                                                                                                             lack">"</font><i>MyServiceTypeBehaviors</i><font color="black">" </font>&gt;</fo                                                                                                                                                             nt>
</PRE>
<P class="intro">Note: the service name must match the configuration name for th                                                                                                                                                             e service implementation.<BR/><BR/>3. Add the following endpoint to your service                                                                                                                                                              configuration:</P>
<PRE>
<font color="blue">&lt;<font color="darkred">endpoint </font><font color="red">c                                                                                                                                                             ontract</font>=<font color="black">"</font>IMetadataExchange<font color="black">                                                                                                                                                             " </font><font color="red">binding</font>=<font color="black">"</font>mexHttpBin                                                                                                                                                             ding<font color="black">" </font><font color="red">address</font>=<font color="b                                                                                                                                                             lack">"</font>mex<font color="black">" </font>/&gt;</font>
</PRE>

<P class="intro">Note: your service must have an http base address to add this e                                                                                                                                                             ndpoint.<BR/><BR/>The following is an example service configuration file with me                                                                                                                                                             tadata publishing enabled:</P>
<PRE>
<font color="blue">&lt;<font color="darkred">configuration</font>&gt;</font>
<font color="blue">    &lt;<font color="darkred">system.serviceModel</font>&gt;<                                                                                                                                                             /font>

<font color="blue">        &lt;<font color="darkred">services</font>&gt;</font>
<font color="blue">            &lt;!-- <font color="green">Note: the service nam                                                                                                                                                             e must match the configuration name for the service implementation.</font> --&gt                                                                                                                                                             ;</font>
<font color="blue">            &lt;<font color="darkred">service </font><font co                                                                                                                                                             lor="red">name</font>=<font color="black">"</font><i>MyNamespace.MyServiceType</                                                                                                                                                             i><font color="black">" </font><font color="red">behaviorConfiguration</font>=<f                                                                                                                                                             ont color="black">"</font><i>MyServiceTypeBehaviors</i><font color="black">" </f                                                                                                                                                             ont>&gt;</font>
<font color="blue">                &lt;!-- <font color="green">Add the following                                                                                                                                                              endpoint. </font> --&gt;</font>
<font color="blue">                &lt;!-- <font color="green">Note: your servic                                                                                                                                                             e must have an http base address to add this endpoint.</font> --&gt;</font>
<font color="blue">                &lt;<font color="darkred">endpoint </font><fo                                                                                                                                                             nt color="red">contract</font>=<font color="black">"</font>IMetadataExchange<fon                                                                                                                                                             t color="black">" </font><font color="red">binding</font>=<font color="black">"<                                                                                                                                                             /font>mexHttpBinding<font color="black">" </font><font color="red">address</font                                                                                                                                                             >=<font color="black">"</font>mex<font color="black">" </font>/&gt;</font>
<font color="blue">            &lt;<font color="darkred">/service</font>&gt;</fo                                                                                                                                                             nt>
<font color="blue">        &lt;<font color="darkred">/services</font>&gt;</font>

<font color="blue">        &lt;<font color="darkred">behaviors</font>&gt;</font>
<font color="blue">            &lt;<font color="darkred">serviceBehaviors</font>                                                                                                                                                             &gt;</font>
<font color="blue">                &lt;<font color="darkred">behavior </font><fo                                                                                                                                                             nt color="red">name</font>=<font color="black">"</font><i>MyServiceTypeBehaviors                                                                                                                                                             </i><font color="black">" </font>&gt;</font>
<font color="blue">                    &lt;!-- <font color="green">Add the follo                                                                                                                                                             wing element to your service behavior configuration.</font> --&gt;</font>
<font color="blue">                    &lt;<font color="darkred">serviceMetadata                                                                                                                                                              </font><font color="red">httpGetEnabled</font>=<font color="black">"</font>true                                                                                                                                                             <font color="black">" </font>/&gt;</font>
<font color="blue">                &lt;<font color="darkred">/behavior</font>&gt                                                                                                                                                             ;</font>
<font color="blue">            &lt;<font color="darkred">/serviceBehaviors</font                                                                                                                                                             >&gt;</font>
<font color="blue">        &lt;<font color="darkred">/behaviors</font>&gt;</font                                                                                                                                                             >

<font color="blue">    &lt;<font color="darkred">/system.serviceModel</font>&gt;                                                                                                                                                             </font>
<font color="blue">&lt;<font color="darkred">/configuration</font>&gt;</font>
</PRE>
<P class="intro">For more information on publishing metadata please see the foll                                                                                                                                                             owing documentation: <a href="http://go.microsoft.com/fwlink/?LinkId=65455">http                                                                                                                                                             ://go.microsoft.com/fwlink/?LinkId=65455</a>.</P>
</DIV>

At this point i have no idea what this is but i guess i have a connection?

I just checked the logs

pi@Serwer:~ $ systemctl status pulseway.service
● pulseway.service - Remotely Monitor and Control IT Systems
   Loaded: loaded (/etc/systemd/system/pulseway.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Mon 2020-01-27 17:46:49 GMT; 8min ago
  Process: 839 ExecStart=/usr/sbin/pulsewayd --no-daemonize (code=exited, status=1/FAILURE)
 Main PID: 839 (code=exited, status=1/FAILURE)

Jan 27 17:46:48 Serwer systemd[1]: Started Remotely Monitor and Control IT Systems.
Jan 27 17:46:48 Serwer pulseway[839]: Starting Pulseway Daemon version 6.5 (2019082205)
Jan 27 17:46:49 Serwer pulseway[839]: Configuration: cannot open file /etc/pulseway/config.xml
Jan 27 17:46:49 Serwer systemd[1]: pulseway.service: Main process exited, code=exited, status=1/FAILURE
Jan 27 17:46:49 Serwer systemd[1]: pulseway.service: Failed with result 'exit-code'.

So i tried to open the config.xml with nano and it wanted to create a new file. So i guess the config file isn't there even after i re-installed pulseway?

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...