Jump to content
jlct021

config.xml Debian 9

Recommended Posts

Posted (edited)

Which is the correct directory for the config.xml file in Debian 9 please?

/etc/pulse/ or /etc/pulseway/ (Agent installed into / etc/pulse/ by default)

Below example config isn't working /  what must we change? (Agent starts with no errors, but password remains visible and device is not showing up in Pulseway)

==============================================

<?xml version="1.0" encoding="utf-8"?>
<config xmlns="http://www.pulseway.com/linuxconfig">
  <!--Pulseway Linux Monitoring Agent - pulseway.com -->

  <!--Account Information
    - Username: ***
    - Password: ***
    - UseCustomServer: enable this option only if you have a dedicated Enterprise Server assigned to your account
    - CustomServerAddress: ***.pulseway.com
  <Account Username=*** Password=*** UseCustomServer=true CustomServerAddress=***.pulseway.com/>
=============================================================

Thanks

 

Edited by jlct021

Share this post


Link to post
Share on other sites

The correct configuration file name is /etc/pulseway/config.xml and it appears that you've removed the double quotes after each XML attribute. Refer to the Setup -> Guide section of the WebApp for a sample configuration for the Linux agent.

-Paul

Share this post


Link to post
Share on other sites

=================================

<!--Account Information
    - Username: administrator
    - Password: ***
    - UseCustomServer: enable this option only if you have a dedicated Enterprise Server assigned to your account
    - CustomServerAddress: ***.pulseway.com
  <Account Username="***" Password="***" UseCustomServer="true" CustomServerAddress="***.pulseway.com"/>

================================

Issue remain. Using below as reference:

Pls provide a link to the Setup -> Guide section of the WebApp you referenced.

Thanks

 

 

 

 

Share this post


Link to post
Share on other sites

That would be https://instanceName.pulseway.com/app/main/setup/guide but it looks like you've deleted the XML end comment marker.

This section is an XML comment and it's ignored by the Pulseway agent:

<!--Account Information
    - Username: administrator
    - Password: ***
    - UseCustomServer: enable this option only if you have a dedicated Enterprise Server assigned to your account
    - CustomServerAddress: ***.pulseway.com

However it's missing the end multi-line comment marker. It should look like this:

<!--Account Information
    - Username: administrator
    - Password: ***
    - UseCustomServer: enable this option only if you have a dedicated Enterprise Server assigned to your account
    - CustomServerAddress: ***.pulseway.com-->

-Paul

Share this post


Link to post
Share on other sites

Thank you, the device is now reflecting in Pulseway. The only line then that actually requires editing is:

<Account Username="" Password="" UseCustomServer="false" CustomServerAddress="" />

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×