Jump to content
PseudoIT

Patching policy history not matching up to actual updates installed

Recommended Posts

Hi Guys,

I'm setting up the patch policies, I've got some strange behaviour - the patching policy history in Pulseway indicates the "Available update didn't match any rule and was ignored." however when logging into the server I can see that update was installed. See the screenshots below - specifically for update 4132216

image.png.b16078d14b1cb8806f8fa818cc777929.pngimage.png.a00fbce13de60bcf81b3af20832c9e87.png

 

Share this post


Link to post
Share on other sites

Hi,

Is it possible that you haven't disabled Windows Automatic Updates? If yes, then when Windows will check for available updates for the windows, then it will install all available updates ignoring the Pulseway policy. In order to avoid this, you will need to disable Windows Automatic Updates on your system.

I believe that this is the correct registry key to disable Automatic Updates for Windows.

According to Microsoft you can use one of the following options. Please choose one.

These are PowerShell command which will create the registry keys:

Set-ItemProperty -Path "HKLM:\Software\Policies\Microsoft\Windows\WindowsUpdate\AU" -Name "NoAutoUpdate" -Value 1 -Type DWord

Set-ItemProperty -Path "HKLM:\Software\Policies\Microsoft\Windows\WindowsUpdate\AU" -Name "AUOptions" -Value 1 -Type DWord

For more details please check the following link.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×