Jump to content

Debian start produces "Got exception signal: 4"


bbb
 Share

Recommended Posts

Hi,

 

It seemed to be working until the 13th Oct (was it auto-upgraded? - the config.xml.sample has the same datestamp as the first failure. the 'my account' 'monitored systems' shows it last logged in as 4.5.3 )

 

Now I can't get beyond:

pulseway: Configuration read successfully!
pulseway: Got exception signal: 4
 
Originally this happened with the existing config.xml. I copied the config.xml.sample, added in my Account details and gradually changed "true"s to "false"s
 
I can connect using the rest api
 
I can't seem to find any clue as to what signal 4 is? Is there a debug option?
 
Thanks,
Link to comment
Share on other sites

  • Staff

Hi,

 

What is the version of Debian? (uname -a; cat /etc/debian_version; openssl version).

Try to a

 rm -rf /usr/sbin/pulseway*

get latest version from our website and give it a try.

If still an issue send me more details about your distro along with config.xml (on PM) I'll try to set up an environment and try to replicate it.

 

Regards,

Mark

Link to comment
Share on other sites

Thanks Mark,
 
uname -a; cat /etc/debian_version; openssl version
Linux b3 2.6.26-2-686 #1 SMP Wed Sep 21 04:35:47 UTC 2011 i686 GNU/Linux
6.0.6
OpenSSL 0.9.8o 01 Jun 2010
 
For the config.xml I've copied the sample, typed in the account and plaintext password, and put a ComputerInformationName in - left everything else. After failing, a diff between config.xml and config.xml.sample shows the plaintext password changed and the xml 'tidied up'.
 
I can remove/reinstall pulseway over ssh but is there a way of diagnosing the fault beforehand? 
 
Thanks,
Link to comment
Share on other sites

  • Staff

Hi,

 

Unfortunately we only support distributions that are running a kernel version of 2.6.32 (or higher). We recommend you to upgrade your kernel to the latest available version by running aptitude update as the root user.

 

Please let us know if you encounter problems with the latest kernel.

 

Regards,

Chris

Link to comment
Share on other sites

Thanks Chris, same problem:

 

[root@b3 09:16:58] $ uname -a
Linux b3 2.6.32-5-686 #1 SMP Tue May 13 16:33:32 UTC 2014 i686 GNU/Linux
 
Oct 16 09:16:48 b3 pulseway: Configuration read successfully!
Oct 16 09:16:55 b3 pulseway: Got exception signal: 4
 
And a diff of config.xml with account details removed:
 
 diff -awB config.xml config.xml.sample
9c10,11
<       <Account Username="myaccount" Password="hex" UseCustomServer="false" CustomServerAddress=""/>
---
>   <Account Username="" Password="" UseCustomServer="false" CustomServerAddress="" />
>
13c15,16
<       <ComputerInformation Name="b3new" Group="Default"/>
---
>   <ComputerInformation Name="" Group="Default" />
>
138d165
< </config>
139a167
> </config>
 
I then change all true to false:
 
<               <OnShutdown Priority="0" Enabled="false"/>
---
>     <OnShutdown Priority="0" Enabled="true" />
 
<               <SSLCertificateExpiration Days="15" Priority="0" Enabled="false"/>
---
>     <SSLCertificateExpiration Days="15" Priority="0" Enabled="true"/>
 
<               <WebSiteNotAvailable Minutes="1" Priority="0" Enabled="false"/>
---
>     <WebSiteNotAvailable Minutes="1" Priority="0" Enabled="true"/>>
 
And same problem
Oct 16 09:25:55 b3 pulseway: Configuration read successfully!
Oct 16 09:26:02 b3 pulseway: Got exception signal: 4
 
Can you give me an idea of what signal 4 means? 
Link to comment
Share on other sites

I have the same problem on Fedora (FC16 x86)

Another thread on this topic is opened here: http://forum.pulseway.com/topic/1277-fedora-client-stopped-working/

The problem started to occur on 13th Oct too....so the similarities between this issue and mine make me believe that the problem is no related to my machine, but to pulseway.

Did you release any update on 12th-13th of October ?

 

Cheers

Bogdan

Link to comment
Share on other sites

Thanks, not sure how I missed your topic!

 

it seems to have upgraded itself at 17:53 13th Oct on my box

 2518926 Oct 13 17:53 /usr/sbin/pulsewayd
   17162 Oct 13 17:53 /usr/sbin/pulseway-update
 
If I copy the old version back in:
2199212 Oct 16 13:55 pulsewayd
  17162 Oct 16 13:55 pulseway-update
 
It logs in OK as 4.4.3, and then upgrades itself to 4.4.5
2518926 Oct 16 13:59 pulsewayd
  17162 Oct 16 13:59 pulseway-update
 
 
And crashes:
Oct 16 13:59:23 b3 pulseway: Configuration read successfully!
Oct 16 13:59:31 b3 pulseway: Got exception signal: 4
 
One problem is, of course, that signal:4 could be anything so there's no way of going further without guessing
The other problem is that there's no way of stopping or backing out of the upgrade, which is bound to cause problems in real world usage.
At the very least a system manager needs notice that it's going to stop working...
 
 
Link to comment
Share on other sites

I want to echo what bbb was saying in that I too had the Linux agent stop working on October 13th.  I received the same messages in the agent log (see below).
 

Oct 17 16:00:43 600Server pulseway: Configuration read successfully!

Oct 17 16:00:44 600Server pulseway: Got exception signal: 4

 

Has a work-around for this issue been discovered or are the Pulseway devs working on a fix?  I'd really like to get the agent running again.

 

Thanks everyone.

Link to comment
Share on other sites

  • Staff

I have the same problem on Fedora (FC16 x86)

Another thread on this topic is opened here: http://forum.pulseway.com/topic/1277-fedora-client-stopped-working/

The problem started to occur on 13th Oct too....so the similarities between this issue and mine make me believe that the problem is no related to my machine, but to pulseway.

Did you release any update on 12th-13th of October ?

Cheers

Bogdan

Hi,

This is your replay from other thread after I tested your configure file with a vanilla FC16 installation:

"Yes, it works. I can see two new machines - one offline and one online.

So, what might cause the problem on my machine ? :("

We don't what you have installed on your machine, we don't know how your machine is configured. All our release we test then against fresh VANILLA distributions. And your config file WORKS with a fresh install of FC16.

Mark

Link to comment
Share on other sites

  • Staff

Thanks Chris, same problem:

[root@b3 09:16:58] $ uname -a

Linux b3 2.6.32-5-686 #1 SMP Tue May 13 16:33:32 UTC 2014 i686 GNU/Linux

Oct 16 09:16:48 b3 pulseway: Configuration read successfully!

Oct 16 09:16:55 b3 pulseway: Got exception signal: 4

And a diff of config.xml with account details removed:

diff -awB config.xml config.xml.sample

9c10,11

< <Account Username="myaccount" Password="hex" UseCustomServer="false" CustomServerAddress=""/>

---

> <Account Username="" Password="" UseCustomServer="false" CustomServerAddress="" />

>

13c15,16

< <ComputerInformation Name="b3new" Group="Default"/>

---

> <ComputerInformation Name="" Group="Default" />

>

138d165

< </config>

139a167

> </config>

I then change all true to false:

< <OnShutdown Priority="0" Enabled="false"/>

---

> <OnShutdown Priority="0" Enabled="true" />

< <SSLCertificateExpiration Days="15" Priority="0" Enabled="false"/>

---

> <SSLCertificateExpiration Days="15" Priority="0" Enabled="true"/>

< <WebSiteNotAvailable Minutes="1" Priority="0" Enabled="false"/>

---

> <WebSiteNotAvailable Minutes="1" Priority="0" Enabled="true"/>>

And same problem

Oct 16 09:25:55 b3 pulseway: Configuration read successfully!

Oct 16 09:26:02 b3 pulseway: Got exception signal: 4

Can you give me an idea of what signal 4 means?

Hi,

Do you have any particular software that will change default core libs (glibc, gcc, kernel, OpenSSL) ?

I'm asking this because I tested your config with a fresh distro install and works. I'm trying to isolate your issue.

Mark

Link to comment
Share on other sites

  • Staff

I want to echo what bbb was saying in that I too had the Linux agent stop working on October 13th. I received the same messages in the agent log (see below).

Has a work-around for this issue been discovered or are the Pulseway devs working on a fix? I'd really like to get the agent running again.

Thanks everyone.

Hi,

What distro (uname -a; cat /etc/issue; openssl version) are you using? Can you, please, PM your config file? (After removing your username and password)

Thanks!

Mark

Link to comment
Share on other sites

"Do you have any particular software that will change default core libs (glibc, gcc, kernel, OpenSSL) ?"
 
Not that I'm aware of (just an old system):
 
[root@b3 17:29:15] $ ldd --version
ldd (Debian EGLIBC 2.11.3-4) 2.11.3
 
 [root@b3 17:30:45] $ uname -a; cat /etc/debian_version; openssl version
Linux b3 2.6.32-5-686 #1 SMP Tue May 13 16:33:32 UTC 2014 i686 GNU/Linux
6.0.10
OpenSSL 0.9.8o 01 Jun 2010
 

The REST API is working if that eliminates anything (such as data collection rather than data reporting)...

Link to comment
Share on other sites

Mark, I understand what you're saying, but since the problem occurred on other systems as well and almost at the same moment in time, after a new version was installed, for me this sort for coincidence is too much ;)

I don't totally exclude the possibility to have an issue with my system, but I will keep follow the thread anyway

 

Cheers

Bogdan

Link to comment
Share on other sites

  • 2 weeks later...
  • 1 month later...

Even with the latest version, this is still an issue. My Linux server is going unmonitored because of whatever this bug is.  Frankly, I am quite tired of seeing "pulseway: Got exception signal: 4" in my logs.

 

Is there any hope of a fix or work-around for this?

Link to comment
Share on other sites

  • Staff

Hi,

 

Would it be possible for you to send a copy of your config.xml file to support [at] pulseway [dot] com (after you removed your account details ofcourse)? Also it would be great if you would also add the output of the 'uname -a' command.

 

Regards,

Chris

Pulseway Support

Link to comment
Share on other sites

Thanks...  Shame they haven't succeeded yet because all it really needs is a flag to prevent auto-upgrades - essential for any enterprise-level software! - and since they already know much about the system (by definition) it shouldn't be too hard to figure out the common factors of those that won't or can't upgrade.

Link to comment
Share on other sites

  • Staff

Hi everyone,

 

Pulseway 4.6.5 comes with a flag that can disable the automatic update functionality. If you're upgrading to 4.6.5 chances are you won't have the setting available in your config.xml so please add the following XML tag inside the <config> tag (but not inside other inner tags):

<AutoUpdate Enabled="true" />

Example:

<?xml version="1.0" encoding="utf-8"?>
<config xmlns="http://www.pulseway.com/linuxconfig">
  <Account Username="" Password="" UseCustomServer="false" CustomServerAddress="" />
  <ComputerInformation Name="" Group="Default" />
  <AllowedCommands>
    <Restart Allowed="true" />
    <ShutDown Allowed="true" />
    <PowerOff Allowed="true" />
    <Suspend Allowed="false" />
    <Hibernate Allowed="false" />
  </AllowedCommands>
  <MonitoredServices>
    <Service Name="cups" DisplayName="CUPS Service" IsDaemon="true" DaemonType="SYSVINIT" Path="" StartParameters="" CanBeStopped="true" Enabled="false" />
    <Service Name="ntpd" DisplayName="NTPD Process" IsDaemon="false" DaemonType="NONE" Path="/usr/sbin/ntpd" StartParameters="-p /var/run/ntp/ntpd.pid -g -u ntp:ntp -i /var/lib/ntp -c /etc/ntp.conf" CanBeStopped="true" Enabled="false" />
    <Service Name="ssh" DisplayName="SSH Daemon" IsDaemon="true" DaemonType="UPSTART" Path="" StartParameters="" CanBeStopped="true" Enabled="false" />
    <Service Name="SuSEfirewall2.service" DisplayName="SuSE Firewall Service" IsDaemon="true" DaemonType="SYSTEMD" Path="" StartParameters="" CanBeStopped="true" Enabled="false" />
  </MonitoredServices>
   <Web>
    <Certificates>
      <Certificate Server="google.com" Port="443" Enabled="false" />
      <Certificate Server="microsoft.com" Port="443" Enabled="false" />
    </Certificates>
    <WebSites>
      <WebSite Url="http://www.google.com" Type="HEAD" Name="Google (using HEAD)" Enabled="false" />
      <WebSite Url="http://www.intel.com" Type="GET" Name="Intel (using GET)" Enabled="false" />
    </WebSites>
  </Web>
  <Network>
    <Ping Server="8.8.8.8" Enabled="false"/>
    <MonitoredPorts>
      <Port Type="TCP" Number="80" Name="Google (port 80)" Address="www.google.com" Enabled="false"/>
      <Port Type="TCP" Number="443" Name="Google (port 443)" Address="www.google.com" Enabled="false"/>
      <Port Type="UDP" Number="53" Name="DNS" Address="127.0.0.1" Enabled="false"/>
    </MonitoredPorts>
    <NetworkInterfaces>
      <Interface Name="eth0" Enabled="false"/>
      <Interface Name="eth1" Enabled="false"/>
    </NetworkInterfaces>
    <WoWAN Port="9" Enabled="false" />
  </Network>
  <Notifications>
    <WhenOffline Enabled="false" />
    <OnOnline Priority="2" Enabled="false" />
    <OnShutdown Priority="0" Enabled="true" />
    <UserLogsIn Priority="2" Enabled="false" />
    <UserLogsOut Priority="3" Enabled="false" />
    <MemoryLow Priority="1" Percentage="10" Enabled="false" />
    <HighCpuUsage Priority="1" Percentage="90" Minutes="5" Enabled="false" />
    <LowCpuUsage Priority="2" Percentage="10" Minutes="5" Enabled="false" />
    <PortClosed Priority="1" Minutes="1" Enabled="false" />
    <ServiceStopped Priority="1" Minutes="1" Enabled="false"/>
    <LowHDDSpace>
      <Hdd Percentage="10" Path="/" Priority="0" Enabled="false"/>
      <Hdd Percentage="20" Path="/home" Priority="1" Enabled="false"/>
    </LowHDDSpace>
    <IpChange Enabled="false"/>
    <PingResponses>
      <PingResponse Address="10.10.10.2" Milliseconds="50" Minutes="15" PriorityOnSlowResponse="1" PriorityOnNoResponse="1" Alias="Printer" Enabled="false" />
      <PingResponse Address="10.10.10.1" Milliseconds="50" Minutes="10" PriorityOnSlowResponse="0" PriorityOnNoResponse="0" Alias="Router" Enabled="false" />
    </PingResponses>
    <SSLCertificateExpiration Days="15" Priority="0" Enabled="true"/>
    <WebSiteNotAvailable Minutes="1" Priority="0" Enabled="true"/>
  </Notifications>
  <MaintenanceMode Enabled="false" />
  <Proxy Host="proxy.host" Port="8080" User="" Password="" Enabled="false" />
  <AutoUpdate Enabled="true" />
</config>
Link to comment
Share on other sites

Thanks Chris, that's good to know for future use - but as the 4.6.5 version fails whether it updates or not, is there a way to stop the 4.4 version updating? If not, is there a way to debug the error. And if not that, what do you suggest we do?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...