Jump to content

How to configure a systemd user service in pulseway?


Milind Patel
 Share

Recommended Posts

By default pulseway reccognizes the systemd services running as root.

i want to configure a service which is running as the current user...

the service is started using the command "systemctl --user start servicename"

the service is placed in the directory "/etc/systemd/user/servicename.service"

 

I have tried using the systemd option in pulseway config, but it is not recognized.

Link to comment
Share on other sites

  • Staff

Hi @Milind Patel,

Usually, Pulseway runs the scripts as a root system account and not as a user account. You can try the below method and see if it works for you.

---> On the remote machine, please consider configuring the PowerShell impersonation by remoting into that affected machine, then launch Pulseway Manager -> Settings -> Runtime. 

Please enter the username and password on this field on the affected system.

If the affected machine is on a domain, domain-level credentials should be used. 

If it is not on a domain, you can use the local admin account credentials and leave the domain field blank.

You may refer to the below screenshot. 

?name=inline822521946.png

Once you have the Powershell impersonation configured on Pulseway Manager, wait for 2-3 minutes, then run the command/script through Pulseway Webapp.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...