Jump to content
George Charlton

ubuntu agent keeps showing as offline

Recommended Posts

Posted (edited)

I have installed the latest Pulseway agent onto a newly installed Ubuntu server and after a couple of issues getting the server registered i was able to do so, this was due to it not having a config.xml file after intallation I renamed the config.xml.sample and added my details and this now shows in my dashboard.

Now that the server is showing in the dashboard it keeps dropping on and offline. The server has a stable internet connection and a windows 10 machine on the same network is not having an issue with dropouts.

Any ideas as to what could be causing the issue are welcome.

Edited by George Charlton

Share this post


Link to post
Share on other sites

Hi George,

Thanks for contacting Pulseway support. Please send us the screenshot showing the error messages which are related to the Pulseway from the Syslog  and send Syslog from the affected machine.

cat /var/log/syslog | grep pulseway

Share this post


Link to post
Share on other sites

Hi Chris,

Below is a section of the syslog that you asked for. If you need any additional informaiton please let me know.

Jun  5 19:42:52 MinecraftSRV pulseway: message repeated 2 times: [ Error while registering computer:SOAP 1.1 fault SOAP-ENV:Server[no subcode]#012"Timeout"#012Detail: connect failed in tcp_connect()]
Jun  5 19:44:27 MinecraftSRV pulseway: Error while registering online:SOAP 1.1 fault SOAP-ENV:Server[no subcode]#012"Timeout"#012Detail: connect failed in tcp_connect()
Jun  5 19:45:13 MinecraftSRV pulseway: Error while registering computer:SOAP 1.1 fault SOAP-ENV:Server[no subcode]#012"Timeout"#012Detail: connect failed in tcp_connect()
Jun  5 19:45:59 MinecraftSRV pulseway: Error while registering computer:SOAP 1.1 fault SOAP-ENV:Server[no subcode]#012"Timeout"#012Detail: connect failed in tcp_connect()
Jun  5 19:47:18 MinecraftSRV pulseway: Error while registering online:SOAP 1.1 fault SOAP-ENV:Server[no subcode]#012"Timeout"#012Detail: connect failed in tcp_connect()

Share this post


Link to post
Share on other sites

Hi,

Thank you for contacting us. This error indicates that the Pulseway agent can not connect to the Pulseway server or that the system to which it connects is not the Pulseway server.

Please check the following:

1) Can you please check if you are using any forward or reverse proxy?
2). Can you resolve url (instance name) on your system?
3. Please make sure that port 443 is open on the firewall.
4. Also make sure that the Pulseways network traffic is not blocked by the UTM.
 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...