Jump to content

ubuntu agent keeps showing as offline


George Charlton
 Share

Recommended Posts

I have installed the latest Pulseway agent onto a newly installed Ubuntu server and after a couple of issues getting the server registered i was able to do so, this was due to it not having a config.xml file after intallation I renamed the config.xml.sample and added my details and this now shows in my dashboard.

Now that the server is showing in the dashboard it keeps dropping on and offline. The server has a stable internet connection and a windows 10 machine on the same network is not having an issue with dropouts.

Any ideas as to what could be causing the issue are welcome.

Edited by George Charlton
Link to comment
Share on other sites

  • Staff

Hi George,

Thanks for contacting Pulseway support. Please send us the screenshot showing the error messages which are related to the Pulseway from the Syslog  and send Syslog from the affected machine.

cat /var/log/syslog | grep pulseway

Link to comment
Share on other sites

Hi Chris,

Below is a section of the syslog that you asked for. If you need any additional informaiton please let me know.

Jun  5 19:42:52 MinecraftSRV pulseway: message repeated 2 times: [ Error while registering computer:SOAP 1.1 fault SOAP-ENV:Server[no subcode]#012"Timeout"#012Detail: connect failed in tcp_connect()]
Jun  5 19:44:27 MinecraftSRV pulseway: Error while registering online:SOAP 1.1 fault SOAP-ENV:Server[no subcode]#012"Timeout"#012Detail: connect failed in tcp_connect()
Jun  5 19:45:13 MinecraftSRV pulseway: Error while registering computer:SOAP 1.1 fault SOAP-ENV:Server[no subcode]#012"Timeout"#012Detail: connect failed in tcp_connect()
Jun  5 19:45:59 MinecraftSRV pulseway: Error while registering computer:SOAP 1.1 fault SOAP-ENV:Server[no subcode]#012"Timeout"#012Detail: connect failed in tcp_connect()
Jun  5 19:47:18 MinecraftSRV pulseway: Error while registering online:SOAP 1.1 fault SOAP-ENV:Server[no subcode]#012"Timeout"#012Detail: connect failed in tcp_connect()
Link to comment
Share on other sites

  • 3 weeks later...
  • Staff

Hi,

Thank you for contacting us. This error indicates that the Pulseway agent can not connect to the Pulseway server or that the system to which it connects is not the Pulseway server.

Please check the following:

1) Can you please check if you are using any forward or reverse proxy?
2). Can you resolve url (instance name) on your system?
3. Please make sure that port 443 is open on the firewall.
4. Also make sure that the Pulseways network traffic is not blocked by the UTM.
 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...