Jump to content

setting up pulseway on openmediavault


Recommended Posts

  • 5 months later...

Hey Denver2020!

 

EDIT:

To install PulseWay from scratch on OpenMediaVault do the follwoing

Make sure your TimeZone is set on OpenMediaVault, this is on the left side of the web interface under the dropdown group System > Date & Time

Enable SSH on the OpenMediaVault server, this is on the left side of the web interface under the dropdown group Services > SSH

Login to the server via SSH

Download the PulseWay Debian 64bit client from the downloads

run the following in the command line

wget https://www.pulseway.com/download/pulseway_x64.deb

Now run the following

dpkg --install pulseway_x64.deb && cp /etc/pulseway/config.xml.sample /etc/pulseway/config.xml

(not acutally sure if you need to copy the config file like that on setup - can't hurt to do it just incase though)

Now run the following

pulseway-registration

Go through the steps to register the system..

--------------------

 

PulseWay not starting after config file updated

First off, lets assume that you have already installed PulseWay and you are in limbo with your config file.

Log into the OpenMediaVault server using SSH

Run the following in the terminal

pulseway-registration

Key 4, to unregister the system

Leave this SSH session open, we will come back to this later.

 

Now let's Log in to the OpenMediaVault Web Interface

On the options to the left you should see Date & Time - this is under the System dropdown group

Click the slider switch to enable the NTP server

Now choose your timezone from the dropdown menu just above this slider switch

Save and apply the change (this should appear at the top of the page)

 

OK, lets go back to the SSH session we left open,

Run the following in the terminal window again

pulseway-registration

Key 1, to register the system

type in your username and passwords - It will ask if you want to start the pulseway service, obviously yes; and it should now start working :)

 

You can run the following in the terminal to change up the config file if you want to enable and disable features

sudo nano /etc/pulseway/config.xml

or 

nano /etc/pulseway/config.xml

 

Edited by David_UiliX
Misunderstood the OG post haha, thought he was having an issue - nope, just wanted to know how to set it up
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...