Jump to content

High CPU for about 5 minutes after startup


gjhilbrands
 Share

Recommended Posts

Hi,

I'm using version 2.8.1 on a XP machine (SP3). After startup the PCMonitorsrv.exe consumes 100% CPU for about 5 minutes, making the computer completely unresponsive. I've checked several setting and read the install instructions, but didn't found any clues what is causing this behaviour. Any Thoughts ?

Kind Regards,

Gertjan

Link to comment
Share on other sites

Hi Johnni,

I enabled the diagnostics. During startup of the PC it produces the following entries in the trace.log:

6-2-2012, 22:53:58.171: [service] PC Monitor Service ver. 2.8.1 build 4390 is starting...

6-2-2012, 22:53:58.265: [service] Increasing process priority to AboveNormal...

6-2-2012, 22:53:58.546: [service] Setting service failure actions...

6-2-2012, 22:53:58.984: [service] Service failure actions set.

6-2-2012, 22:53:59.015: [service] Setting operation task to '"C:\Program Files\PC Monitor\pcmontask.exe"'...

6-2-2012, 22:53:59.015: [service] Adding the app to startup not required.

6-2-2012, 22:53:59.015: [service] Starting local server...

6-2-2012, 22:54:00.046: [service] Local server started.

6-2-2012, 22:54:00.046: [service] Service started.

6-2-2012, 22:54:09.343: [service] Updating server settings...

6-2-2012, 22:54:13.468: [service] Updating server settings...

6-2-2012, 22:54:14.828: [Local Server] Client registered for EECPC\EEC with identifier 051e2411-f5b4-43f0-9933-5ee833a620fb

6-2-2012, 22:54:17.343: [Local Server] Client unregistered (timeout) for EECPC\EEC with identifier 051e2411-f5b4-43f0-9933-5ee833a620fb

6-2-2012, 22:54:18.484: [service] Updating server settings...

6-2-2012, 22:54:23.906: [service] Updating server settings...

6-2-2012, 22:54:24.093: [Local Server] Client registered for EECPC\EEC with identifier 051e2411-f5b4-43f0-9933-5ee833a620fb

6-2-2012, 22:54:31.562: [service] Updating server settings...

6-2-2012, 22:54:33.656: [service] Updating server settings...

6-2-2012, 22:54:41.281: [service] Updating server settings...

6-2-2012, 22:54:47.890: [service] Updating server settings...

6-2-2012, 22:55:05.671: [service] Updating server settings...

6-2-2012, 22:55:05.843: [service] Updating server settings...

6-2-2012, 22:55:06.250: [Local Server] Client registered for EECPC\EEC with identifier 051e2411-f5b4-43f0-9933-5ee833a620fb

6-2-2012, 22:55:08.546: [service] Updating server settings...

6-2-2012, 22:55:13.500: [service] Updating server settings...

6-2-2012, 22:55:15.562: [service] Server settings updated (3/15).

6-2-2012, 22:55:15.578: [service] Server settings updated (3/15).

6-2-2012, 22:55:15.578: [service] Updating server notifications...

6-2-2012, 22:55:15.578: [service] Updating server notifications...

6-2-2012, 22:55:15.656: [service] Server settings updated (3/15).

6-2-2012, 22:55:15.656: [service] Updating server notifications...

6-2-2012, 22:55:15.859: [service] Server settings updated (3/15).

6-2-2012, 22:55:15.859: [service] Updating server notifications...

6-2-2012, 22:55:16.109: [service] Data publishing took 70031,25ms (including computer info)

6-2-2012, 22:55:16.171: [service] Data sampling took 70375ms

6-2-2012, 22:55:16.281: [service] Server notifications updated (0/0).

6-2-2012, 22:55:16.484: [service] Server notifications updated (0/0).

6-2-2012, 22:55:16.703: [service] Server notifications updated (0/0).

6-2-2012, 22:55:16.906: [service] Server notifications updated (0/0).

6-2-2012, 22:55:17.109: [service] Server notifications updated (0/0).

6-2-2012, 22:55:17.312: [service] Server notifications updated (0/0).

6-2-2012, 22:55:17.515: [service] Server notifications updated (0/0).

6-2-2012, 22:55:20.156: [service] Server settings updated (3/15).

6-2-2012, 22:55:20.156: [service] Updating server notifications...

6-2-2012, 22:55:20.328: [service] Server notifications updated (0/0).

6-2-2012, 22:55:28.140: [service] Server settings updated (3/15).

6-2-2012, 22:55:28.140: [service] Updating server notifications...

6-2-2012, 22:55:28.250: [service] Server settings updated (3/15).

6-2-2012, 22:55:28.250: [service] Updating server notifications...

6-2-2012, 22:55:28.359: [service] Server settings updated (3/15).

6-2-2012, 22:55:28.390: [service] Updating server notifications...

6-2-2012, 22:55:28.453: [service] Server settings updated (3/15).

6-2-2012, 22:55:28.453: [service] Updating server notifications...

6-2-2012, 22:55:28.562: [service] Server notifications updated (0/0).

6-2-2012, 22:55:28.562: [service] Server settings updated (3/15).

6-2-2012, 22:55:28.562: [service] Updating server notifications...

6-2-2012, 22:55:28.671: [service] Server settings updated (3/15).

6-2-2012, 22:55:28.671: [service] Updating server notifications...

6-2-2012, 22:55:28.750: [service] Server notifications updated (0/0).

6-2-2012, 22:55:28.859: [service] Server notifications updated (0/0).

6-2-2012, 22:55:28.953: [service] Server notifications updated (0/0).

6-2-2012, 22:55:29.062: [service] Server notifications updated (0/0).

6-2-2012, 22:55:30.000: [service] Server notifications updated (0/0).

I am not sure if it's normal, or abnormal behaviour showing here. Do you ?

Best Regards,

Gert-Jan

Link to comment
Share on other sites

Hi,

Thanks for your reply. The diagnostics tab that I used in v2.8.1 doesn't seem to exist in Beta 5, so I wasn't able to create a new trace log with beta 5. It seems however that the beta5 does not conserve as much CPU power as v2.8.1 did, so for now the problem seems solved .... I'll monitor the new version for a while and see if upgrading really did the trick ....

Best Regards,

Gert-Jan

Link to comment
Share on other sites

Found the diagnostics tab....

I included the last startup section of the trace.log file:

(The 100% CPU consumption for 5 minutes, as described in the start of this log, does not occur with this - beta 5 -version, so problem seems resolved)

11-2-2012, 17:07:46.625: [service] PC Monitor Service ver. 2.9 beta 5 build 4419 is starting...

11-2-2012, 17:07:46.671: [service] Increasing process priority to AboveNormal...

11-2-2012, 17:07:46.843: [service] Setting service failure actions...

11-2-2012, 17:07:47.171: [service] Service failure actions set.

11-2-2012, 17:07:47.187: [service] Setting operation task to '"C:\Program Files\PC Monitor\pcmontask.exe"'...

11-2-2012, 17:07:47.187: [service] Adding the app to startup not required.

11-2-2012, 17:07:47.187: [service] Starting local server...

11-2-2012, 17:07:47.468: [service] Local server started.

11-2-2012, 17:07:47.468: [service] Service started.

11-2-2012, 17:07:53.953: [service] Updating server settings...

11-2-2012, 17:07:55.359: [Local Server] Client registered for EECPC\EEC with identifier 0c2380e5-bdb4-4e7c-a9e1-283f3d6c1e55

11-2-2012, 17:08:02.843: [Local Server] Client unregistered (timeout) for EECPC\EEC with identifier 0c2380e5-bdb4-4e7c-a9e1-283f3d6c1e55

11-2-2012, 17:08:25.431: [Local Server] Client registered for EECPC\EEC with identifier 0c2380e5-bdb4-4e7c-a9e1-283f3d6c1e55

11-2-2012, 17:08:29.244: [Local Server] Client unregistered (timeout) for EECPC\EEC with identifier 0c2380e5-bdb4-4e7c-a9e1-283f3d6c1e55

11-2-2012, 17:08:34.431: [Local Server] Client registered for EECPC\EEC with identifier 0c2380e5-bdb4-4e7c-a9e1-283f3d6c1e55

11-2-2012, 17:08:37.338: [service] Checking for plugins changes has been skipped as plugins have not been loaded yet.

11-2-2012, 17:08:37.338: [service] Checking for alerts took 8375ms

11-2-2012, 17:08:55.369: [service] Checking for plugins changes has been skipped as plugins have not been loaded yet.

11-2-2012, 17:08:55.853: [service] Checking for alerts took 3406,25ms

11-2-2012, 17:09:02.838: [service] Server settings updated (3/15).

11-2-2012, 17:09:02.838: [service] Updating server notifications...

11-2-2012, 17:09:02.994: [service] Data publishing took 61994,2974ms (including computer info)

11-2-2012, 17:09:03.009: [service] Data sampling took 67900,5474ms

11-2-2012, 17:09:04.463: [service] Server notifications updated (0/0).

11-2-2012, 18:07:18.166: [service] Data publishing took 4171,875ms (including computer info)

11-2-2012, 19:28:19.759: [service] Data publishing took 5765,625ms (including computer info)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...