Jump to content

Server2019 - Could not establish trust relationship


aussiewinkle
 Share

Recommended Posts

Setting up a test environment for Pulseway,  brand new server 2019 install, have loaded everything up as per normal, hoever when trying to validate another win2019 server for monitoring, i get the cold not establish trust relationship for the SSL/TLS secure channel with authorit '******.*****.***.**'

 

any ideas?

Link to comment
Share on other sites

  • Staff

Hi @aussiewinkle,

This error usually is shown if the Pulseway agent from the monitored machine can not connect to your Pulseway server. Please check the following:

1. Are you using Proxy? If yes, then please configure it from the Pulseway Manager -> Settings -> Proxy on your monitored system.

2. Can you resolve the DNS name from the system which can not connect? (nslookup)

3. Is it possible that some of root certificates are missing or that there is some mismatch between enabled  ciphers on your Pulseway server and remote system? Please open the Pulseway Webapp using Internet explorer on the system from which the Pulseway agent fails to connect to your Pulseway server? Any errors? Please send us the screenshot?

4. If the TLS 1.0 and 1.1 is disabled, then please make sure, that the TLS 1.2 is enabled for .Net Framework 4.0. Please run the following command to enable it and then reboot your system.

Set-ItemProperty -Path "HKLM:\Software\Microsoft\.NETFramework\v4.0.30319" -Name "SchUseStrongCrypto" -Value 1 -Type DWord

Note: Allows TLS 1.2 connections for .NET Framework 4.0 applications when .NET Framework 4.5 is installed

Please let us know how it goes.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...