Jump to content

Raspberry Pi 3


DaveG
 Share

Recommended Posts

Hi All,

I am trying to install the agent on a Pi 3 with Raspbian Stretch Lite running.  It looks like it has installed but its not showing up on the device list and the password in the config.xml does not get encrypted.  I am a bit of a noob when it comes to all things Linux and I have just followed the website instructions.

Has anybody else come across this?

thanks

Dave

Link to comment
Share on other sites

  • Staff

Hi DaveG,

Have you started the Pulseway service after you saved the config.xml file?

The password will be encrypted after you start the Pulseway service.

Also, please make sure that the Pulseway you have installed libssl1.0.2 and updated the symlinks, so Pulseway is using correct SSL libraries. For more details please check the following link

 

Link to comment
Share on other sites

Once you've installed the Linux agent and edited your config.xml, you will likely need to install the OpenSSL 1.0.0 package from Debian Jessie and then enable the Pulseway daemon and start it. The basic steps on my Pi2b were:

systemctl stop pulseway
wget http://ftp.debian.org/debian/pool/main/o/openssl/libssl1.0.0_1.0.1t-1+deb8u8_armhf.deb
dpkg -i libssl1.0.0_1.0.1t-1+deb8u8_armhf.deb
ldconfig
systemctl enable pulseway
systemctl start pulseway

Hopefully then you should find that the password gets encrypted in config.xml and your Pi shows up in your web console.

Edited by ghodder
Link to comment
Share on other sites

  • 1 month later...
  • 5 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...