Jump to content

pcmonitord process problem


jdsupport
 Share

Recommended Posts

Hi All,

 

i'm running 2 ubuntu 12.04 servers (we are virtualized on vsphere 5.1).. i followed the install guide and the monitors are up and running.. however i've got one sticky issue and i'm not sure whats causing it. randomly it seems the pcmonitord process just stops. if i restart it from the command line they report.. then maybe an hour to 4 hrs later it stops and i have to restart the process again.

 

any ideas? the windows servers are working great and no issues with the software at all. 

 

i love the software, its honestly already paid for itself... wish i had found you earlier! :)

 

thanks

 

-monte

Link to comment
Share on other sites

the daemon log wasn't turned on.. so i enabled it.. i did find the following in the syslog.. i'm awaiting the next drop from the dashboard and service quit to look at the daemon log.. 

 

Dec 13 09:21:21 swb1 pcmonitor: Error while registering online:Error 503 fault: SOAP-ENV:Server[no subcode]#012"HTTP/1.1 503 Service Unavailable"#012Detail: The service is unavailable.
Dec 13 09:21:38 swb1 pcmonitor: Error while registering computer:Error 503 fault: SOAP-ENV:Server[no subcode]#012"HTTP/1.1 503 Service Unavailable"#012Detail: The service is unavailable.
Dec 13 09:21:45 swb1 pcmonitor: Error while registering computer:Error 503 fault: SOAP-ENV:Server[no subcode]#012"HTTP/1.1 503 Service Unavailable"#012Detail: The service is unavailable.

Link to comment
Share on other sites

I'm seeing a similar issue on 2 Ubuntu 12.04.3 servers.

One is running kernel 3.2.0-57-generic and the other is on 3.5.0-44-generic.

UFW on both systems is turned off.

My error messages from daemon.log

Dec 11 16:28:19 pcmonitor: Error while registering computer:Error 503 fault: SOAP-ENV:Server[no subcode] "HTTP/1.1 503 Service Unavailable" Detail: The service is unavailable.

Dec 11 16:29:08 pcmonitor: Got sisegv

I can try to provide more information about our systems if it would help find the cause.

Thanks for the great product!

Edited by leopard1996
Link to comment
Share on other sites

  • 3 months later...

I have the same problem with 5 virtual machines running Ubuntu 12.04 LTS.

After starting the virtual machines, only 1 of the 5 did appear online in the PC Monitor app.

The other 4 are offline, so the PC Monitor process was not started or crashed afterwards.

 

When I tried to start the service (service pcmonitor start), I got the following message in /var/log/syslog.

Apr  4 20:05:37 pcmonitor: Error while registering online:SOAP 1.1 fault: SOAP-ENV:Client[no subcode]#012"Timeout"#012Detail: connect failed in tcp_connect()
Apr  4 20:06:09 pcmonitor: Error while registering online:SOAP 1.1 fault: SOAP-ENV:Client[no subcode]#012"Timeout"#012Detail: connect failed in tcp_connect()

 

I have installed PC Monitor two days ago (02-Apr-14) from the site.

 

Is this a known bug?
 

Link to comment
Share on other sites

  • Staff

Hello Gerben,

 

Please make sure that you have no firewalls blocking the other 4 machines. Also, issue the start command and watch the log to see if anything is outputted.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...