Jump to content
Joe Savage

Office365 + SMTP - Email Notifications

Recommended Posts

Hi all,

I hope you're having a great day and are keeping safe.

I'm having an issue with setting up email notifications via SMTP to Office365. I've followed the document on setting Pulseway up to talk with Office365. I've also been in touch with support on this and haven't been satisfied with their answer.

Have any of you linked this up successfully? If so, which IP addresses do you have whitelisted? Is there anything obvious I'm missing?

I've set up a relay and can't see any attempt at mail delivery via 365.

Cheers!

Joe

Something Went Wrong.jpg

Share this post


Link to post
Share on other sites

Hi Joe,

A couple of things you should try:

  • Use the same FROM address as the username
  • If you have 2FA configured try using an App Password
  • Make sure you use encryption and port 587
  • Use a username in format of user@domain.com instead of DOMAIN\user

Let me know how it goes,

-Paul

Share this post


Link to post
Share on other sites

Thanks Paul - I've tried those with no effect.

Is there anything else you can suggest?

Thanks again for your speedy reply.

 

Joe

Share this post


Link to post
Share on other sites

That's odd, have you tried an online SMTP test tool like this (https://www.smtper.net/)? If this shows the same error you may need to reach out to their support to see maybe you're missing a setting. I am not familiar with Office 365.

-Paul

Share this post


Link to post
Share on other sites

Cheers Paul - had time to look at it properly today and got it working.

For reference:

  1. Ensured Authenticated SMTP was turned on for the account
  2. Ensured SMTP relay was set up via 365
  3. Used XXXX-com.mail.protection.outlook.com, Port 25, SSL/TLS on

Cheers! Have a good weekend.

Share this post


Link to post
Share on other sites
2 minutes ago, Joe Savage said:

Cheers Paul - had time to look at it properly today and got it working.

For reference:

  1. Ensured Authenticated SMTP was turned on for the account
  2. Ensured SMTP relay was set up via 365
  3. Used XXXX-com.mail.protection.outlook.com, Port 25, SSL/TLS on

Cheers! Have a good weekend.

Thanks for sharing this! Glad to hear everything works now.

Have a great weekend as well!

-Paul

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Atrium
      I am working on building an Ad Hoc report in PSA to be able to list on-hand products and serial numbers assigned to that product for inventorying purposes.
      I know the Serial Numbers are tracked, and are listed when deploying them as assets in Service Desk.  Is there a way to get that information to display in a report to possibly inventory product & serial number?
    • By Joe Savage
      Hi there,
      This might be a bit of a long shot - but I have an end client who's interested in deploying custom Teams issues with Pulseway (as there aren't many users in-office for obvious reasons).
      I've attempted to deploy this by pushing a batch script, to copy the backgrounds from a shared location. The backgrounds folder in question is located in the user's roaming appdata (%appdata%\Microsoft\Teams\Backgrounds\Uploads). For this reason I wasn't able to use %username% correctly in my batch script, as the script is being run by some Pulseway service, rather than as the local user account.
       
      Please let me know if you've any ideas and have a great day.
       
      Cheers,
      Joe
    • By kappnet
      Hi,
      I am looking for a script that can trigger a 3rd party patch policy ad-hoc outside the policy schedule.
      It´s going to be used to start the installation process of software on newly registered machines in a "Computer registered" workflow.
      If there is anyone with another take on that I´m all ears.

      Best regards

      Mike

       
       
    • By Andreas Schwanke
      Hi! 
      I was searching for an option in the mobile Android app to switch the language! Perhaps I'm just blind... 
      Thanks,
      BR, 
      Andreas 
    • By JaydenE55
      I would like to make a script that will run a batch file on my desktop. How do i do that?
×
×
  • Create New...