Jump to content
AndrewT

Group Policy editor errors

Recommended Posts

I'm trying to edit/create a new log alert.

1. When adding a new Event ID to an existing alert (comma delimited) and press Save, I get the following error in the console, and so the change cannot be saved.

TypeError: n.split is not a function
    at e (Configuration?v=9UgYGKSsgKBU9Z8hKYeBn1ZGSfClMiErmwarSJ-k9Nk1:1)
    at h (Configuration?v=9UgYGKSsgKBU9Z8hKYeBn1ZGSfClMiErmwarSJ-k9Nk1:1)
    at b.i.save (Configuration?v=9UgYGKSsgKBU9Z8hKYeBn1ZGSfClMiErmwarSJ-k9Nk1:1)
    at fn (eval at compile (Angular?v=p7XkODdFRlnxHp13elrK938iS1GuRjGvjEN1SZnD5Xk1:218), <anonymous>:4:341)
    at f (Angular?v=p7XkODdFRlnxHp13elrK938iS1GuRjGvjEN1SZnD5Xk1:258)
    at b.$eval (Angular?v=p7XkODdFRlnxHp13elrK938iS1GuRjGvjEN1SZnD5Xk1:139)
    at b.$apply (Angular?v=p7XkODdFRlnxHp13elrK938iS1GuRjGvjEN1SZnD5Xk1:139)
    at HTMLFormElement.<anonymous> (Angular?v=p7XkODdFRlnxHp13elrK938iS1GuRjGvjEN1SZnD5Xk1:258)
    at HTMLFormElement.dispatch (jquery-2.1.4.min.js:3)
    at HTMLFormElement.r.handle (jquery-2.1.4.min.js:3)

 

2. I create a new alert, then press Save at the bottom of the page, I'm immediately logged out and the new alert is not saved. The console shows the following error.

POST https://xxxxxxxxx.pulseway.com/app/configuration/setgrouppolicyxml 501 (Not Implemented)
(anonymous) @ Angular?v=p7XkODdFRlnxHp13elrK938iS1GuRjGvjEN1SZnD5Xk1:99
q @ Angular?v=p7XkODdFRlnxHp13elrK938iS1GuRjGvjEN1SZnD5Xk1:95
g @ Angular?v=p7XkODdFRlnxHp13elrK938iS1GuRjGvjEN1SZnD5Xk1:92
(anonymous) @ Angular?v=p7XkODdFRlnxHp13elrK938iS1GuRjGvjEN1SZnD5Xk1:124
$eval @ Angular?v=p7XkODdFRlnxHp13elrK938iS1GuRjGvjEN1SZnD5Xk1:139
$digest @ Angular?v=p7XkODdFRlnxHp13elrK938iS1GuRjGvjEN1SZnD5Xk1:136
$apply @ Angular?v=p7XkODdFRlnxHp13elrK938iS1GuRjGvjEN1SZnD5Xk1:139
(anonymous) @ Angular?v=p7XkODdFRlnxHp13elrK938iS1GuRjGvjEN1SZnD5Xk1:258
dispatch @ jquery-2.1.4.min.js:3
r.handle @ jquery-2.1.4.min.js:3
Webapp?v=q_Itvkrsn7cHaFoxY6naxi7fk3CIzlYQcu8SG1P96v01:1 Response Error 501 {data: "<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Stric…> ↵ </fieldset></div> ↵</div> ↵</body> ↵</html>

logging out

 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Tim Roewen
      Hi there,
      We are using both PSA and RMM from Pulseway.
      In the last few weeks we are experiencing some weird behavior between PSA and RMM.
      We don't use the and never set up the integration, but after we delete the settings both in PSA and RMM, it still comes back.
      It is irritating us enormously and the support isn't helpful after creating several tickets.
      I hope someone can help us with this issue.
      King regards,
      Tim Roewen
       
    • By malvarez
      I have a Linux Server that reports as up-to-date version 5.4.
      Is this correct? Because I can't move it in Pulseway 6.0 to another Organization or Site. I get an error message that the agent requires an update.
    • By Your PCMD
      6.0 dropped for me this morning. I hate it and I tell you why.
      After going through the painstaking process of setting up my Organizations, Sites and Group, I am left with no endpoints visible. The only place I can find them is under Systems > Systems (this needs to be reworded as it is redundant - maybe Systems > Endpoints OR Endpoints > Systems, your welcome for that tip), anyway, while under that location I can see all my endpoints but they are ALL in the wrong location with no way that I can see to move them to where they should be.
      There needs to be a way to move them either with a dropdown or a drag and drop approach.
      I did log into an endpoint remotely to look at the Pulseway Manager but no, cannot change which  Organization, Site or Group it would belong too. However this should be a moot point as there is no way I am going to log in remotely to every single endpoint so that brings it down to only one way of doing it, through the webapp. 
      Can we get this looked into ASAP as this should be way up there on the list.
       
       
    • By Matt Wilson
      I beat my head with this for a few hours tonight, so I wanted to post here in case anyone else needs it.
      I am doing some custom html using css to make some kick ass email templates. I wanted to place the ticket url into the html but not show the link and control the hover link formatting. When I used [%Ticket URL%] in an existing <a href...blah blah blah> tag, it doesn't just insert the URL, it inserts its own entire href tag with the URL as the display text thus breaking the link. 
      When I finally woke up, I realized to do this in your own custom html, you need to build the href link manually using the psa url and adding the [%Ticket ID%] field at the end. My finished code line looks like this:
      <a style="color: #8db9e3;" href="https://psa.pulseway.com/MSP/TicketEdit.aspx?ID=[%Ticket ID%]"><span style="color:#adb3b9">Click here to open in Support Portal</span></a>
      Hope this helps someone.
    • By Matt Wilson
      I have a support ticket where I asked this question and got a reply that it could be looked at in the future. Just placing it here to ensure it gets put on Feature request list and so others can comment.
      When sales tax is added to invoice in PSA then synced to Quickbooks via PSA QB SYNC, it defaults to sales tax code G. In Canada, G is GST @ 5% by default (and correctly so) out of the box. H is for HST is dependent on province. In my case, HST at 13% is setup in PSA, but when the invoice syncs over to Quickbooks, it imports/syncs as tax code G (at 5%). I have to edit EVERY SINGLE INVOICE.I just need to tell PSA to use a defined sales tax code when syncing to QB.  
      I would consider this more of a bug than a feature. What's the point of automation if you have to go back and edit everything?  
      Connected...I sync invoices over to QB so I can use my custom invoice template. Its been said elsewhere, but we REALLY need a way to edit/create our own HIGH QUALITY professional and modern looking invoices in PSA. No offense, but the few invoice templates that exist look horrible.

      As always, I appreciate all you guys are doing and know you are swamped with current RD and RMM centralized rollout. Keep up the good work!
×