Jump to content
McHenry

Discovery probe failing

Recommended Posts

Hi,

I am testing Pulseway and have deployed a few agents, all good.

One of the agents I have configured as a discovery probe, all good.

The probe has located a number but not all of the computers on the LAN.

At another site the probe is not locating ANY other computers on the LAN.

Any ideas as to what may be causing this?

Share this post


Link to post
Share on other sites

Hi McHenry,

Please check the following Knowledge Base article: https://intercom.help/pulseway/features/deployment/network-discovery-and-automatic-deployment

Note:

1. that the Probe will discover all the systems in the same subnet. If the missing systems are on the different subnet, then you will not see them, because we are scanning for all the systems which are on the same subnet.

2 if the ICMP packets are blocked on the firewall, then we will not see these systems.

3. If the Pulseway agent was installed on the remote system once, then we will not discover that system for the second time unless you will delete the following registry key from the system which is marked as a probe.

HKEY_LOCAL_MACHINE\SOFTWARE\MMSOFT Design\PC Monitor\Discovery\Systems

Share this post


Link to post
Share on other sites

Hi Chris,

Thanks for the reply. I am not sure why the probe is not working.

1) The machines are all on the same subnet

2) No firewall blocking

3) Agent never been installed before

Regardless I have used Group Policy to deploy so all good. I'd love to know how to disable the desktop icon as it causes user questions every time they see it.

Plus I'd like to know how to enforce locking of the setings when deploying via GP

Thanks

 

Share this post


Link to post
Share on other sites

Hi McHenry,

In order to disable the desktop icon please run the following powershell line:

Remove-Item 'C:\Users\*\Desktop\Pulseway Manager.lnk'

 

Regarding your other query - lock one system and take a note of the following registry values:

HKLM:\SOFTWARE\MMSOFT Design\PC Monitor\PreventChanges
HKLM:\SOFTWARE\MMSOFT Design\PC Monitor\PreventChangesPassword
HKLM:\SOFTWARE\MMSOFT Design\PC Monitor\PreventChangesPasswordCtrl

Then put the values into this powershell script:
Set-ItemProperty -Path "HKLM:\Software\MMSOFT Design\PC Monitor\" -Name PreventChanges -Value "Enter the saved PreventChanges from the machine you've just configured"
Set-ItemProperty -Path "HKLM:\Software\MMSOFT Design\PC Monitor\" -Name PreventChangesPassword -Value "Enter the saved PreventChangesPassword from the machine you've just configured"
Set-ItemProperty -Path "HKLM:\Software\MMSOFT Design\PC Monitor\" -Name PreventChangesPasswordCtrl -Value "Enter the saved PreventChangesPasswordCtrl from the machine you've just configured"

Add the three powershell lines into an automation script, link it to a task and run it to set the configuration lock on your systems.

Share this post


Link to post
Share on other sites

Hi @McHenry,

Regarding the issues with the Deployment - Please check the following article, it might help you to troubleshoot the issue.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×