Jump to content
Steven Shapiro

Can't get PC Monitor to run

Recommended Posts

I am running Ubuntu 12.04.4 on an older Compaq nc6000 laptop. I got the .deb file downloaded and I ran the install as directed, receiving this...

 

******************************************************************
*** Beware, you must create the configuration file for PCMonitor!
*** We provide an example of complete configuration in
*** /etc/pcmonitor directory (config.xml.sample). You can use it
*** to create your own custom configuration and then
*** start pcmonitor using command: /etc/init.d/pcmonitor start
*****************************************************************

 

So I edited the config.xml.sample file, entering my username and password, then tried to start pcmonitor as directed in the last line...

 

start pcmonitor using command: /etc/init.d/pcmonitor start

 

However, nothing happens. I don't see any gui for pcmonitor, I checked the site and my iOS app and I don't see the machine.

 

I'm very noobish for linux, so its very likely I am missing something. Please help.

Share this post


Link to post
Share on other sites

Have you copied the configuration sample to the real configuration file name?

 

sudo cp /etc/pcmonitor/config.xml.sample /etc/pcmonitor/config.xml

sudo /etc/init.d/pcmonitor restart

 

This is standard procedure on most linux apps. Yes, I believe that the GUI app from the native linux agent is still in development but you can configure everything with a configuration file too.

 

Paul

Share this post


Link to post
Share on other sites

I did as you suggested and I get the statement that pcmonitor restarted and OK on the right, but when I look on the mobile app, I still only see my desktop & not this laptop. Are there any other items I need to alter in the config?

Share this post


Link to post
Share on other sites

Yes , you have to edit the newly created /etc/pcmonitor/config.xml and configure it . Enter username password and other settings , they are all commented in the sample.

Share this post


Link to post
Share on other sites

Same issue here getting pcmonitor: Configuration: expected ' or "  in log showing on 2 Ubuntu systems (new installs)

Have config.xml configured with my correct account details

Share this post


Link to post
Share on other sites

Same issue here getting pcmonitor: Configuration: expected ' or "  in log showing on 2 Ubuntu systems (new installs)

Have config.xml configured with my correct account details

 

Please make sure that in the config file there are no symbols other than ' and " (Take a close look at the Proxy node).

Share this post


Link to post
Share on other sites

I'm having the same issue, do you see any thing wrong with the config.xml file?

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<config    xmlns="http://www.pulseway.com/linuxconfig">
  <Account Username="**********************" Password="*********************" UseCustomServer="false" CustomServerAddress="" />
  <ComputerInformation Name="Ubuntu" Group="Default" />
  <AllowedCommands>
    <Restart Allowed="true" />
    <ShutDown Allowed="true" />
    <PowerOff Allowed="true" />
    <Suspend Allowed="true" />
    <Hibernate Allowed="true" />
  </AllowedCommands>
  <Notifications>
    <WhenOffline Enabled="false" />
    <OnOnline Enabled="false" />
    <OnShutdown Enabled="false" />
    <MemoryLow Percentage="10" Enabled="false" />
    <HighCpuUsage Percentage="90" Minutes="1" Enabled="false" />
    <LowCpuUsage Percentage="10" Minutes="1" Enabled="false" />
    <PortClosed Minutes="1" Enabled="false" />
    <LowHDDSpace Enabled="false">
      <Hdd Percentage="20" Path="/" Enabled="true" />
    </LowHDDSpace>
    <IpChange Enabled="true"/>
    <PingResponses Enabled="false">
        <PingResponse PriorityOnSlowResponse="1" PriorityOnNoResponse="0" Minutes="5" Miliseconds="50" Alias="Printer" Address="10.10.10.2" Position="1"/>
    </PingResponses>
  </Notifications>
  <Network>
    <Ping Server="" Enabled="false" />
    <MonitoredPorts>
      <Port Type="TCP" Number="80" Name="80" Address="www.google.com"/>
    </MonitoredPorts>
    <NetworkInterfaces>
      <Interface Name="eth0" />
    </NetworkInterfaces>
    <WoWAN Port="9" Enabled="false"/>
  </Network>
  <MaintenanceMode>false</MaintenanceMode>
  <Proxy Enabled=“false” Host="proxy.host" Port="8080" User="proxy.user" Password="proxy.password"/>
</config>

Share this post


Link to post
Share on other sites

Hi, I understand if I don't get reply, this is because the thread is really old.  I am having issues with a Raspberry Pi running the latest version of Pulseway. I have gotten everything installed correctly via Terminal, but the PC is NOT showing up on my app or the Web App. Is there something wrong with the .xml file for the config stuff. I have looked at the above stuff, if there is a reply, I will send the config info in a image file. Everything that I have done has not resolved the issue. Any suggestions would be greatly appreciated. 

Regards, Zach

Share this post


Link to post
Share on other sites

Hi Zach,

Did you run the pulseway-registration tool to register the system? We no longer support entering the username / password directly into the configuration file.

-Paul

Share this post


Link to post
Share on other sites
Posted (edited)
14 hours ago, Paul said:

Hi Zach,

Did you run the pulseway-registration tool to register the system? We no longer support entering the username / password directly into the configuration file.

-Paul

Can you send me a link to the registration tool?

Edited by TechManZach
Didn't insert a reply.

Share this post


Link to post
Share on other sites

Hey Zach,

It's already included with the Pulseway agent package and globally linked. If you just call it like this it should work:

sudo pulseway-registration

-Paul

Share this post


Link to post
Share on other sites

Hey Zach,

We've just released an update which may have caused that to happen. If you were to try again now it should work.

-Paul

Share this post


Link to post
Share on other sites

I did the wrong password, and now it says successful on everything. But, I still can't see anything on the app. I did get a notification saying error encountered getting the notification. It was listed as critical.

Share this post


Link to post
Share on other sites

Hi Zach,

Please send an email with the config.xml file and the logs to support@pulseway.com. We'll get in touch with you.

Best regards,

Mark

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...